Bug 1273963 - Email address validation does not work in Request information form
Email address validation does not work in Request information form
Status: CLOSED DUPLICATE of bug 1110649
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Provisioning (Show other bugs)
5.5.0
Unspecified Unspecified
low Severity low
: GA
: 5.5.0
Assigned To: Greg McCullough
Dave Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-21 11:17 EDT by Pavol Kotvan
Modified: 2015-11-11 15:37 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-22 10:16:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: Bug
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pavol Kotvan 2015-10-21 11:17:56 EDT
Description of problem:
When user is provisioning new VM, email address is mandatory on the Request information form page. It is possible to put any string into this field.

Version-Release number of selected component (if applicable):
5.5.0.6-beta1.2.20151014155446_ed40d96

How reproducible:
always

Steps to Reproduce:
1. Add new provider
2. Provision new VM
3. Put any string/letter into "E-Mail *" field without specifying domain suffix (@domain.xyz)

Actual results:
VM can be provisioned without providing email address in correct format.

Expected results:
Email field validator should tell you that your email address is not in correct format and it won't let you provision new VM.

Additional info:
Comment 2 Greg McCullough 2015-10-22 10:16:16 EDT

*** This bug has been marked as a duplicate of bug 1110649 ***

Note You need to log in before you can comment on or make changes to this bug.