Bug 1274002 - Missing chown causes Permission denied errors
Missing chown causes Permission denied errors
Status: CLOSED ERRATA
Product: Red Hat Developer Toolset
Classification: Red Hat
Component: devtoolset-4-toolchain-container (Show other bugs)
DTS 4.0 RHEL 7
Unspecified Unspecified
unspecified Severity unspecified
: alpha
: 4.0
Assigned To: Marek Polacek
Miloš Prchlík
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-21 13:22 EDT by Marek Polacek
Modified: 2015-11-16 10:57 EST (History)
7 users (show)

See Also:
Fixed In Version: devtoolset-4-toolchain-docker-4-4
Doc Type: Bug Fix
Doc Text:
No description necessary
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-16 10:57:31 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:2049 normal SHIPPED_LIVE new container image: rhscl/devtoolset-4-toolchain-rhel7 2016-04-21 13:15:49 EDT

  None (edit)
Comment 3 Radek Zima 2015-10-27 06:05:09 EDT
Hi,

there is conflict between packages in buildroot rhel-7.2 vs. rhel-7.1. It is caused by wrong specification in FROM directive in your Docker configuration file. You should use there:

FROM rhel:7.1

More information can be found here: https://mojo.redhat.com/docs/DOC-1023066#jive_content_id_Base_image

Regards,
Radek
Comment 4 Marek Polacek 2015-10-27 06:13:34 EDT
Thanks, that seems to help, but now I'm getting another error :(

2015-10-27 06:09:45,522 - atomic_reactor.plugin - INFO - running plugin instance with args: '{'parent_registry_insecure': True, 'parent_registry': u'rcm-img-docker01.build.eng.bos.redhat.com:5001'}'
2015-10-27 06:09:45,522 - atomic_reactor.plugins.pull_base_image - INFO - pulling base image 'rhel7:1' from registry 'rcm-img-docker01.build.eng.bos.redhat.com:5001'
2015-10-27 06:09:45,522 - atomic_reactor.core - INFO - pulling image 'rcm-img-docker01.build.eng.bos.redhat.com:5001/rhel7:1' from registry
2015-10-27 06:09:45,522 - atomic_reactor.core - DEBUG - image = 'rcm-img-docker01.build.eng.bos.redhat.com:5001/rhel7:1', insecure = 'True'
2015-10-27 06:09:50,638 - atomic_reactor.util - INFO - wait_for_command
2015-10-27 06:09:50,639 - atomic_reactor.util - DEBUG - Trying to pull repository rcm-img-docker01.build.eng.bos.redhat.com:5001/rhel7 ...
2015-10-27 06:09:50,666 - atomic_reactor.util - ERROR - {"errorDetail":{"message":"Tag 1 not found in repository rcm-img-docker01.build.eng.bos.redhat.com:5001/rhel7"},"error":"Tag 1 not found in repository rcm-img-docker01.build.eng.bos.redhat.com:5001/rhel7"}

Before, that worked:

2015-10-26 11:40:59,808 - atomic_reactor.plugins.pull_base_image - INFO - pulling base image 'rhel7:latest' from registry 'rcm-img-docker01.build.eng.bos.redhat.com:5001'
2015-10-26 11:40:59,808 - atomic_reactor.core - INFO - pulling image 'rcm-img-docker01.build.eng.bos.redhat.com:5001/rhel7:latest' from registry
2015-10-26 11:40:59,808 - atomic_reactor.core - DEBUG - image = 'rcm-img-docker01.build.eng.bos.redhat.com:5001/rhel7:latest', insecure = 'True'
2015-10-26 11:40:59,909 - atomic_reactor.util - INFO - wait_for_command
2015-10-26 11:40:59,910 - atomic_reactor.util - DEBUG - Trying to pull repository rcm-img-docker01.build.eng.bos.redhat.com:5001/rhel7 ...

Any hints?
Comment 5 Marek Polacek 2015-10-27 07:29:18 EDT
Strike that, I think I've made a mistake of using ":" instead of "."; oh well.  Trying again...
Comment 6 Marek Polacek 2015-10-27 10:39:58 EDT
All right, I believe fixed now:

$ docker run -ti 35adb1256afe /bin/bash
bash-4.2$ whoami
default
bash-4.2$ pwd
/opt/app-root/src
bash-4.2$ touch foo
bash-4.2$ ls
foo
Comment 8 Miloš Prchlík 2015-11-02 06:14:55 EST
Verified for docker image devtoolset-4-toolchain-docker-4-5 (devtoolset-4.0-rhel-7-docker-candidate-20151027121210 tag).
Comment 10 errata-xmlrpc 2015-11-16 10:57:31 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-2049.html

Note You need to log in before you can comment on or make changes to this bug.