Bug 1274004 - The statement "default is an empty stickysession and nofailover=Off and the values received via the MCMP CONFIG message are ignored when using CreateBalancers 1 in mod_cluster" is not true with mod_cluster 1.2.6.Final and later version.
The statement "default is an empty stickysession and nofailover=Off and the v...
Status: CLOSED DEFERRED
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Documentation (Show other bugs)
6.4.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: eap-docs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-21 13:27 EDT by Dasharath Masirkar
Modified: 2016-04-07 07:28 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Build Name: 23087, Administration and Configuration Guide-6.4 Build Date: 08-10-2015 16:59:36 Topic ID: 5242-684432 [Latest]
Last Closed: 2015-10-28 11:25:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dasharath Masirkar 2015-10-21 13:27:21 EDT
Describe the issue:

In JBoss EAP 6 Administration and configuration guide https://access.redhat.com/documentation/en-US/JBoss_Enterprise_Application_Platform/6.4/html-single/Administration_and_Configuration_Guide/index.html#Configure_the_Enterprise_Application_Platform_to_Accept_Requests_From_an_External_HTTPD1 

Section :  ⁠17.4.6. mod_cluster Configuration on Apache HTTP Server

state that "when using CreateBalancers 1, default is an empty stickysession and nofailover=Off and the values received via the MCMP CONFIG message are ignored"

Suggestions for improvement:
With mod_cluster 1.2.6.Final and later statement "because the default is an empty stickysession and nofailover=Off and the values received via the MCMP CONFIG message are ignored" is not true, as this is fixed via https://bugzilla.redhat.com/show_bug.cgi?id=958991. Now with mod_cluster 1.2.6.Final and later version stickiness settings are still picked up from JBoss mod_cluster configuration even when using CreateBalancers 1. Hence following is not applicable and should be removed from documentation to avoid the confusion.

"While using the value 1, do not forget to configure the balancer in the ProxyPass directive, because the default is an empty stickysession and nofailover=Off and the values received via the MCMP CONFIG message are ignored."

Additional information:
Refer  https://bugzilla.redhat.com/show_bug.cgi?id=958991 and https://access.redhat.com/solutions/182813
Comment 1 anrobert 2015-10-28 11:25:49 EDT
Migrated to JIRA -> https://issues.jboss.org/browse/JBEAP-1675

Note You need to log in before you can comment on or make changes to this bug.