Bug 1274066 - 0008761: Dracut - "cat: write error: Broken pipe" only in rescue mode
0008761: Dracut - "cat: write error: Broken pipe" only in rescue mode
Status: CLOSED DUPLICATE of bug 1223888
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: dracut (Show other bugs)
7.1
x86_64 Linux
unspecified Severity medium
: rc
: ---
Assigned To: dracut-maint
Release Test Team
:
Depends On:
Blocks: 1289485
  Show dependency treegraph
 
Reported: 2015-10-21 15:55 EDT by Brian O'Regan
Modified: 2016-02-23 08:57 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-23 08:57:59 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
CentOS 8761 None None None Never

  None (edit)
Description Brian O'Regan 2015-10-21 15:55:55 EDT
Description of problem:
Dracut drop error "cat: write error: Broken pipe" when i try to generate ramfs 
In normal mode there is no errors.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
mount --bind /dev /mnt/sysimage/dev
mount --bind /proc /mnt/sysimage/proc
mount --bind /sys /mnt/sysimage/sys
chroot /mnt/sysimage
dracut -fv /boot/initramfs-$(uname -r) $(uname-r)
Comment 2 Jan Stodola 2016-01-25 12:03:00 EST
I was able to reproduce with RHEL-7.1 (dracut-033-240.el7), but not with RHEL-7.2 (dracut-033-359.el7).

Brian, could you please retest if the issue is still present in RHEL-7.2?
Thank you
Comment 3 Brian O'Regan 2016-02-23 08:16:42 EST
Tested on 7.2 and it's working perfectly.

Thanks Jan
Comment 4 Jan Stodola 2016-02-23 08:57:59 EST
Thanks for retesting.

Closing the bug per comment 3.

*** This bug has been marked as a duplicate of bug 1223888 ***

Note You need to log in before you can comment on or make changes to this bug.