Bug 1274136 - [DOCS] High-level application health checks section needs more info
[DOCS] High-level application health checks section needs more info
Status: CLOSED NOTABUG
Product: OpenShift Container Platform
Classification: Red Hat
Component: Documentation (Show other bugs)
3.1.0
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: brice
Vikram Goyal
Vikram Goyal
:
Depends On:
Blocks: 1267216
  Show dependency treegraph
 
Reported: 2015-10-21 23:40 EDT by brice
Modified: 2018-05-08 20:30 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-02-02 00:27:47 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description brice 2015-10-21 23:40:08 EDT
The section on high-level application health checks can do with more details:

- needs an example
- which components would need to be tested?
- what actions would need to be taken if it fails?
- how does OpenShift facilitate these high-level checks?
- how do you specify the check and response?

This BZ comes out of this PR:

https://github.com/openshift/openshift-docs/pull/1070
Comment 2 Eric Rich 2016-07-01 10:41:09 EDT
Today we have a few options to complete this. 

   1: Implement a pod level script that while checking the health of a pod also checks the health of the 
       application as a whole. 

       - Note, this is not what we want to recommend but it is currently he most viable solution, and is
          the simplest one to implement. It should be noted that this could be implemented as a "monitor" 
          pod, completely outside of the application as well. 

   2: Implement a maintenance or health check Job [0]. This container or image can be used, to preform 
       the checks that an entire application is up and working as you would expect. 

      - Note, while one job is great an will meet the need, it really only becomes helpful if the job can 
         be scheduled [1], or kicked off regularly. So until this is worked into the product (Kubernetes) 
         this solution is limited. 

[0] https://docs.openshift.com/enterprise/3.2/dev_guide/jobs.html
[1] https://github.com/kubernetes/kubernetes/issues/2156
Comment 3 Vikram Goyal 2017-12-30 21:50:36 EST
@Brice - can this be a part of the new Day 2 guide?
Comment 4 brice 2018-02-02 00:27:47 EST
Vikram, I'll agree that the Day Two Guide fulfills this BZ.

The current section that I initially intended to be elaborated on mentions consulting with the admin to create health checks. This PR is for the day two guide:

https://github.com/openshift/openshift-docs/pull/7258

I don't thin it's necessary to do anything else with the content. I'll close this BZ.

If there's any disagreements, let me know.
Comment 5 brice 2018-02-02 00:28:00 EST
Vikram, I'll agree that the Day Two Guide fulfills this BZ.

The current section that I initially intended to be elaborated on mentions consulting with the admin to create health checks. This PR is for the day two guide:

https://github.com/openshift/openshift-docs/pull/7258

I don't thin it's necessary to do anything else with the content. I'll close this BZ.

If there's any disagreements, let me know.

Note You need to log in before you can comment on or make changes to this bug.