Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1274154 - After build complete , the build pod status are Error.
Summary: After build complete , the build pod status are Error.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Build
Version: 3.0.0
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: ---
Assignee: kconner
QA Contact: Wenjing Zheng
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-10-22 06:59 UTC by Wang Haoran
Modified: 2015-11-23 14:25 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-11-23 14:25:16 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Wang Haoran 2015-10-22 06:59:37 UTC
Description of problem:
After the build complate, the build pod status are Error, should be Complete.

Version-Release number of selected component (if applicable):
openshift v3.0.2.901-61-g568adb6
kubernetes v1.1.0-alpha.1-653-g86b4e77
oc v3.0.2.901-61-g568adb6

How reproducible:
always

Steps to Reproduce:
1.create a project
$oc new-project test
2.Create amq application from template in web console using template eap6-amq-sti
3.check the build status whether the build is complete or not.
$ oc get build
4. if the build is complete in step 3, then check the pod status
$oc get pod

Actual results:
[root@ose secrets]# oc get build
NAME        TYPE      FROM      STATUS     STARTED
eap-app-1   Source    Git@1.1   Complete   7 minutes ago
[root@ose secrets]# oc get pod
NAME                  READY     STATUS    RESTARTS   AGE
eap-app-1-29ehs       0/1       Running   0          21s
eap-app-1-build       0/1       Error     0          8m
eap-app-amq-1-i647v   0/1       Running   0          7m


Expected results:

the pod "eap-app-1-build"  status should be Complete
Additional info:

Comment 2 Ben Parees 2015-10-26 19:53:51 UTC
this looks like it is specific to the EAP image or the AMQ template.  I'm also guessing it's fixed by now, but the templates can't be validated until the new 1.1.x images are published.

Wang, when you go to validate this, please make sure you are using imagestream definitions and templates from the 1.1.x branch:
https://github.com/jboss-openshift/application-templates/tree/1.1.x

Kevin, I think you can just mark this ON_QA once the images are published.

Comment 3 Wang Haoran 2015-10-27 01:53:55 UTC
Ben, will validate this after new images released.

Comment 4 Wang Haoran 2015-10-27 05:48:02 UTC
the bug was verified using the eap image with tag 1.1

Comment 5 Brenton Leanhardt 2015-11-23 14:25:16 UTC
This fix is available in OpenShift Enterprise 3.1.


Note You need to log in before you can comment on or make changes to this bug.