Bug 1274199 - No sample repository displaying under "Git Repository URL" when create app from image on web console
No sample repository displaying under "Git Repository URL" when create app fr...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console (Show other bugs)
3.1.0
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Scott Dodson
Yanping Zhang
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-22 04:56 EDT by Yanping Zhang
Modified: 2015-10-27 12:04 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-27 12:04:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ose-web (133.72 KB, image/png)
2015-10-22 05:10 EDT, Yanping Zhang
no flags Details
origin-web (173.18 KB, image/png)
2015-10-22 05:11 EDT, Yanping Zhang
no flags Details

  None (edit)
Description Yanping Zhang 2015-10-22 04:56:17 EDT
Description of problem:
When create app from image on web console, on creation page, there is no sample repository displaying under "Git Repository URL", so users would not know which repo to use.

Version-Release number of selected component (if applicable):
AtomicOpenShift/3.1/2015-10-21.4

How reproducible:
Always

Steps to Reproduce:
1.Login on web console, try to create app from image, such as python.
2.On creation page, set the "Git Repository URL".

Actual results:
2.There is no sample repository displaying under "Git Repository URL".

Expected results:
2.There should be a sample repository displaying under "Git Repository URL" that users could try it.

Additional info:
There is a sample repository displaying under "Git Repository URL" on origin env.
Comment 1 Yanping Zhang 2015-10-22 05:10 EDT
Created attachment 1085456 [details]
ose-web
Comment 2 Yanping Zhang 2015-10-22 05:11 EDT
Created attachment 1085457 [details]
origin-web
Comment 3 Jessica Forrester 2015-10-22 10:11:46 EDT
This is because old versions of the builder image streams are being created in the openshift namespace.  The file examples/image-streams/image-streams-rhel7.json has the correct annotations.

Scott can you make sure the right image streams are being created by the installer?
Comment 4 Scott Dodson 2015-10-22 11:15:05 EDT
Yanping,

When you say origin env, how is that environment installed? I'm curious how the examples get deployed there.

I've updated ansible so enteprise environments should be better now.

https://github.com/openshift/openshift-ansible/pull/726
Comment 5 Yanping Zhang 2015-10-23 02:54:16 EDT
Scott, My origin env is started from aws image such as devenv-fedora_2517 using openshift start, after server is started, create image streams with examples/image-streams/image-streams-rhel7.json or examples/image-streams/image-streams-centos7.jsonin openshift namespace.

Since the code in pull726 is not merged, I will test on ose env after the code is contained in a new puddle.
Comment 6 Scott Dodson 2015-10-23 09:29:39 EDT
Yanping,

We'd like QE to test the PR before merging it. Here's how to do that, from your checkout of openshift-ansible do the following :

git checkout -b sdodson-examples-sync master
git pull https://github.com/sdodson/openshift-ansible.git examples-sync

Then run the installer on a clean environment.
Comment 7 Yanping Zhang 2015-10-26 22:59:29 EDT
Installed ose env with pr726.
Try to create app from images/quickstarts on web console, there is sample repo under "Repository URL" now.
The issue has been fixed, so move the bug to Verified.
Comment 8 Scott Dodson 2015-10-27 12:04:52 EDT
Reference PR has been merged into ansible, marking this CLOSED CURRENTRELEASE

Note You need to log in before you can comment on or make changes to this bug.