Bug 127425 - crash in intf.run(id, dispatch, configFileData) anaconda line 1081
crash in intf.run(id, dispatch, configFileData) anaconda line 1081
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: anaconda (Show other bugs)
3.0
ia64 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-07 20:34 EDT by Phil
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-07 21:50:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Phil 2004-07-07 20:34:48 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040616

Description of problem:
When installing on IA64 using network install, the following python
trace screen comes up and exit aborts

Traceback (most recent call last):  
File "/usr/bin/anaconda", line      
1081, in ?                             
     intf.run(id, dispatch,             
 configFileData)                        
   File                                 
"/usr/src/build/335668-ia64/install//  
 usr/lib/anaconda/text.py", line 471,   
 in run
  File                                 
"/usr/src/build/335668-ia64/install//  
usr/lib/anaconda/dispatch.py", line    
157, in gotoNext                       
  File                                 
"/usr/src/build/335668-ia64/install//  
usr/lib/anaconda/dispatch.py", line    
225, in moveStep                       
  File                                 
"/usr/src/build/335668-ia64/install//  
usr/lib/anaconda/packages.py", line    
160, in readPackages
   File                                 
 "/usr/src/build/335668-ia64/install//  
 usr/lib/anaconda/installmethod.py",    
 line 68, in readComps                  
   File                                 
 "/usr/src/build/335668-ia64/install//  
 usr/lib/anaconda/urlinstall.py",       
 line 60, in readCompsViaMethod         
   File                                 
 "/usr/src/build/335668-ia64/install//  
 usr/lib/anaconda/hdrlist.py", line     
 920, in groupSetFromCompsFile
KeyError: base

This is a IA64 system so no video, no keyboard, no mouse. I am
installing through the remote console.  I did a network ftp and nfs
install and both brought up the same message. 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. network nfs install rh3 for IA64
2. enter normal setup params, no firewall.
3. fails after entering root password

Actual Results:  install exits abnormally, saying it's safe to reboot
the system. the stack trace is included in problem description

Expected Results:  should have asked me to select the packages to
install. 

Additional info:
Comment 1 Jeremy Katz 2004-07-07 21:50:47 EDT
It looks like you have a malformed tree without the proper comps file.
 Note that when copying CDs, you should _only_ copy the binary cds and
not the extras or doc cd into the directory structure.

Note You need to log in before you can comment on or make changes to this bug.