Bug 1274252 - "Unable to connect to Neutron" message on horizon
"Unable to connect to Neutron" message on horizon
Status: CLOSED DUPLICATE of bug 1260410
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-django-horizon (Show other bugs)
5.0 (RHEL 6)
All Linux
unspecified Severity medium
: ---
: 5.0 (RHEL 6)
Assigned To: Matthias Runge
Ido Ovadia
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-22 07:25 EDT by Pratik Pravin Bandarkar
Modified: 2018-02-08 06:00 EST (History)
5 users (show)

See Also:
Fixed In Version: python-django-horizon-2014.1.5-2.el7ost, python-django-horizon-2014.1.5-2.el6ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-23 16:20:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pratik Pravin Bandarkar 2015-10-22 07:25:11 EDT
Description of problem:

From horizon, if we click on "instance" tab following error popup:
---
"Unable to connect to Neutron" 
---

Version-Release number of selected component (if applicable):
openstack-dashboard-2014.1.5-1.el6ost.noarch
python-django-horizon-2014.1.5-1.el6ost.noarch

How reproducible:
100%

Steps to Reproduce:
1. update openstack-dashboard to 2014.1.5-1
2. from horizon --> click on instance tab.
3.

Actual results:

From horizon, if we click on "instance" tab following error popup:
---
"Unable to connect to Neutron" 
---

Expected results:
error should not display on horizon portal.


Additional info:
Comment 2 Pratik Pravin Bandarkar 2015-10-22 07:28:17 EDT
After digging deeper I found that its similar issue mentioned in:
---
https://bugs.launchpad.net/horizon/+bug/1349841
---

As mentioned in comment #11, I updated "/usr/share/openstack-dashboard/openstack_dashboard/api/neutron.py" file and the error went away. I will report this issue to engineering team. 

So, for time-being we can follow below workaround:
----
- take backup of "/usr/share/openstack-dashboard/openstack_dashboard/api/neutron.py"
- Replace:
[...]
         fips = FloatingIpManager(request)
         if fips.is_supported():<===
[...]

 with:
[...]
         fips = FloatingIpManager(request)
         if True:
[...]


- restart httpd service. 
________________
Comment 4 Matthias Runge 2015-10-23 16:20:04 EDT
There is already a fixed, tracking bug is
https://bugzilla.redhat.com/show_bug.cgi?id=1260410

*** This bug has been marked as a duplicate of bug 1260410 ***

Note You need to log in before you can comment on or make changes to this bug.