Bug 127437 - DNS and Sendmail issue!!
DNS and Sendmail issue!!
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: sendmail (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Woerner
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-08 03:21 EDT by Narayanan Subramaniam
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-16 05:43:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Narayanan Subramaniam 2004-07-08 03:21:28 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4)
Gecko/20030821 Epiphany/1.0

Description of problem:

Dear all,

i had setup dns on my mail server.

Following is the mailserver setup

Mail server hostname : pstn.ho
Local nranch domains server connecting to this server
1 : hostname is branch1.alw
2 : hostname is branch2.thr
3 : hostname is branch3.tvm

The reqmt is that mails from any branch domain to ho should not
be masqueraded. Mails from pstn.ho to internet should be masqueraded as
well mails from any branch to internet. Mail fetching from internet to
local user deliver is acheived using procmail. The above setup is running
without any problem. I had not set any dns on my server. Because of
that mails to certain domains are rejected because of DNS problem.
My actual domain pstn.com is hosted with our local ISP .When i am
sending  mails to internet, it was rejected because of DNS
problem.Please suggest how should i set the dns with the present
setup. Is it possible to setup a dns with follwing entries

pstn.ho 10.0.0.1 (Forward,reverse , and slave zone)
pstn.com 63.23.12.33( slave zone )
branch1.alw 10.0.0.10 (Forward ,reverse and slave zone)
branch2.alw 10.0.0.11 (Forward ,reverse and slave zone)
branch3.alw 10.0.0.12(Forward ,reverse and slave zone)

I tried with this but still mails to local domains are showing problem.
please suggest.

Thanks in advance

Narayanan S

Version-Release number of selected component (if applicable):
sendmail-8.12.8-4 and bind-9.2.1-16

How reproducible:
Didn't try


Actual Results:  mails to certains server in internet are rejected.
Any mails to local domains and branches are sent.

Expected Results:  The setup is functional if i am able to send mails
to all branches and  to pstn.ho without masquerading and mails to
internet from branches and pstn.ho completely masqueraded. 

Additional info:
Comment 1 Suzanne Hillman 2004-07-15 13:52:34 EDT
This looks like something for which you would be best off going
through support, and not bugzilla.

Log in here: https://www.redhat.com/apps/support/

Note You need to log in before you can comment on or make changes to this bug.