This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1274376 - Noticeable delay between selecting SmartProxy server role and when SmartProxy Affinity is populated
Noticeable delay between selecting SmartProxy server role and when SmartProxy...
Status: CLOSED WONTFIX
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.4.0
Unspecified Unspecified
unspecified Severity medium
: GA
: cfme-future
Assigned To: Gregg Tanzillo
Niyaz Akhtar Ansari
ui:doc
:
Depends On:
Blocks: 1291727
  Show dependency treegraph
 
Reported: 2015-10-22 11:19 EDT by Thom Carlin
Modified: 2017-06-07 14:45 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Known Issue
Doc Text:
This release of Red Hat CloudForms corrects a delay between enabling the SmartProxy server role, and its visibility to users in the UI when SmartPRoxy Affinity is selected under Zones.
Story Points: ---
Clone Of:
: 1291727 (view as bug list)
Environment:
Last Closed: 2017-06-07 14:45:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: CFME Core


Attachments (Terms of Use)

  None (edit)
Description Thom Carlin 2015-10-22 11:19:21 EDT
Description of problem:

After selecting SmartProxy server role, if the user goes immediately to the Zone and selects SmartProxy Affinity, the UI displays No servers have the SmartProxy role.  After a bit, the UI is properly populated.

Version-Release number of selected component (if applicable):

5.4.3.1.20151013111241_1c155a5

How reproducible:

100%

Steps to Reproduce:
1. Define Infrastructure Provider
2. Enter Provider Credentials
3. Refresh Relationships and Power States
4. Configure > Configuration, Settings accordion
5. Select "Server "EVM [1]" (current)"
6. Server Control > Server Roles
7. Select SmartProxy
8. Click Save
9. Immediately go to: Zone "Default Zone" > SmartProxy Affinity tab
10. 
Actual results:

No servers found with SmartProxy role
Results populated after a minute or so

Expected results:

"Assign Hosts and Datastores to Embedded SmartProxies in Zone 'Zone: Default Zone'" fully populated

Additional info:

UI should wait for results to be populated
Comment 4 Dave Johnson 2016-09-27 17:07:45 EDT
Satyajit, please review these and potentially redirect to Niyaz as appropriate.
Comment 6 Chris Pelland 2017-06-07 14:45:38 EDT
This BZ has been closed since it was opened on a version of CloudForms that has reached the end of its lifecycle.  If you find that this bug is still relevant, please open a new BZ against the relevant supported version of CloudForms.

Note You need to log in before you can comment on or make changes to this bug.