Bug 1274425 - Windows - rhq-storage-wrapper.conf.new is missing
Windows - rhq-storage-wrapper.conf.new is missing
Status: CLOSED CURRENTRELEASE
Product: JBoss Operations Network
Classification: JBoss
Component: Productization (Show other bugs)
JON 3.3.4
Unspecified Unspecified
unspecified Severity medium
: CR01
: JON 3.3.4
Assigned To: Simeon Pinder
Filip Brychta
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-22 12:53 EDT by Filip Brychta
Modified: 2015-10-29 11:55 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-29 11:55:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Filip Brychta 2015-10-22 12:53:35 EDT
Description of problem:
To successfully apply fix from bz1229978 it's necessary to change JMX_OPTS in rhq-storage-wrapper.conf therefore there should be rhq-storage-wrapper.conf.new file containing following change:
# Additional JVM parameters (quotes ARE needed)
wrapper.java.additional.1="-ea"
wrapper.java.additional.2="-javaagent:"%RHQ_STORAGE_HOME%\lib\jamm-0.2.5.jar""
wrapper.java.additional.3="%heap_min%"
wrapper.java.additional.4="%heap_max%"
wrapper.java.additional.5="%heap_new%"
wrapper.java.additional.6="%heap_dump_on_OOMError%"
wrapper.java.additional.7="%heap_dump_dir%"
wrapper.java.additional.8="-XX:+UseConcMarkSweepGC"
wrapper.java.additional.9="-XX:+CMSParallelRemarkEnabled"
wrapper.java.additional.10="-XX:SurvivorRatio=8"
wrapper.java.additional.11="-XX:MaxTenuringThreshold=1"
wrapper.java.additional.12="-XX:CMSInitiatingOccupancyFraction=75"
wrapper.java.additional.13="-XX:+UseCMSInitiatingOccupancyOnly"
wrapper.java.additional.14="-XX:+UseParNewGC"
wrapper.java.additional.15="-Dcassandra.jmx.local.port=%jmx_port%"
wrapper.java.additional.16="-Dignore1"
wrapper.java.additional.17="-Dignore2"
wrapper.java.additional.18="-Dlog4j.configuration=log4j-server.properties"
wrapper.java.additional.19="-Dlog4j.defaultInitOverride=true"
wrapper.java.additional.20="-Dignore3"

Version-Release number of selected component (if applicable):
JON3.3.4.ER2

How reproducible:
Always

Steps to Reproduce:
1. install JON3.3.0.GA
2. apply the patch


Actual results:
There is no rhq-storage-wrapper.conf.new


Expected results:
There should be rhq-storage-wrapper.conf.new with change described above
Comment 1 Simeon Pinder 2015-10-24 06:48:19 EDT
This if fixed with the following two commits to jon.git:
c16a86f3085e9d
9d7017de52881f

The .new version should only have the suggested updates made in a manner that doesn't disrupt customers who may have modified since GA.
Comment 2 Simeon Pinder 2015-10-24 07:09:12 EDT
Moving to ON_QA as available for test in latest brew build:
https://brewweb.devel.redhat.com/buildinfo?buildID=462976

*Note* jon-server-patch-3.3.0.GA.zip from above maps to CR01 build of JON 3.3.4.
Comment 3 Filip Brychta 2015-10-26 07:53:32 EDT
Verified on
Version :	
3.3.0.GA Update 04
Build Number :	
e9ed05b:aa79ebd

Note You need to log in before you can comment on or make changes to this bug.