Bug 1274442 - Rebase the kernel to Linus' 4.5 tree
Rebase the kernel to Linus' 4.5 tree
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: kernel-aarch64 (Show other bugs)
7.3
aarch64 Unspecified
urgent Severity urgent
: rc
: 7.3
Assigned To: Mark Langsdorf
Erico Nunes
: Rebase
Depends On:
Blocks: 1313485 1274397
  Show dependency treegraph
 
Reported: 2015-10-22 13:52 EDT by Mark Langsdorf
Modified: 2016-11-03 18:15 EDT (History)
1 user (show)

See Also:
Fixed In Version: kernel-aarch64-4.5.0-0.34.el7
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-03 18:15:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark Langsdorf 2015-10-22 13:52:08 EDT
Description of problem:
The current kernel-aarch64 is based on Linus' 4.2 kernel. Take advantage of the evolution of the kernel upstream and the fact that RHELSA 7.3 was a Development Preview and rebase the kernel to Linus' 4.4 kernel.

Version-Release number of selected component (if applicable):
kernel-aarch64-4.2.0-0.21.el7
Comment 1 Mark Langsdorf 2016-02-01 12:16:35 EST
Changing the title to reflect I'm rebasing to v4.5 instead of v4.4 due to the schedule slip.
Comment 2 Mark Langsdorf 2016-05-10 15:12:42 EDT
Bad kernel maintainer! Update your bugs.
Comment 4 Erico Nunes 2016-07-28 08:47:30 EDT
Verified that out current tree for kernel aarch64 has been rebased to 4.5.0 from linus since kernel-4.5.0-0.32.el7:

commit b562e44f507e863c6792946e4e1b1449fbbac85d
Author: Linus Torvalds <torvalds@linux-foundation.org>
Date:   Sun Mar 13 21:28:54 2016 -0700

    Linux 4.5

$ git tag --contains b562e44f507e863c6792946e4e1b1449fbbac85d
kernel-4.5.0-0.32.el7
kernel-4.5.0-0.33.el7
kernel-4.5.0-0.34.el7
kernel-4.5.0-0.35.el7
kernel-4.5.0-0.36.el7.test
kernel-4.5.0-0.37.el7
kernel-4.5.0-0.38.el7
kernel-4.5.0-0.39.el7
kernel-4.5.0-0.40.el7
kernel-4.5.0-0.41.el7
kernel-4.5.0-0.42.el7
kernel-4.5.0-0.43.el7
kernel-4.5.0-0.44.el7
kernel-4.5.0-0.45.el7
kernel-4.5.0-0.46.el7
kernel-4.5.0-0.47.el7
kernel-4.5.0-0.48.el7
v4.5


uname -r displays 4.5.0-*:
[root@amd-seattle-03 ~]# uname -r
4.5.0-0.48.el7.aarch64
Comment 6 errata-xmlrpc 2016-11-03 18:15:32 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2145.html

Note You need to log in before you can comment on or make changes to this bug.