This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 127451 - The QIntValidator checks input not correct
The QIntValidator checks input not correct
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: qt (Show other bugs)
1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-08 09:44 EDT by Frank Büttner
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-12 05:00:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Frank Büttner 2004-07-08 09:44:57 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; de-AT; rv:1.4.1)
Gecko/20031114

Description of problem:
The QIntValidator check the input not correct.
sample code:
Pruefer1_9=new QIntValidator(0,9,this);
LN1->setValidator(Pruefer1_9);

LN1 is a QLineEdit
Pruefer1_9 is a QIntValidator

Version-Release number of selected component (if applicable):
qt-3.1.2-14

How reproducible:
Always

Steps to Reproduce:
1. try to use the QIntValidator


Actual Results:  in this sample you can input integers >9

Expected Results:  do not allow integer >8

Additional info:

to resolve the problem is use the QT Lib version 3.3.2
Comment 1 Ngo Than 2004-07-12 05:00:20 EDT
there'a new qt-3.3.2 package for FC1 on ftp.kde.org. You could
download  this version from here. Thanks for your report
Comment 2 Frank Büttner 2004-07-12 05:53:42 EDT
Thanks. When will this package become a fedora update?
And where can i found this packe on the ftp.kde.org server?
Comment 3 Ngo Than 2004-07-13 12:00:16 EDT
oh, sorry. it's only for FC1 here. Ok, i will try to make update for fc1

Note You need to log in before you can comment on or make changes to this bug.