This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1274527 - AMD-Vi: Event logged [IO_PAGE_FAULT device=00:11.0 domain=0x0004 address=0x0000000000000000 flags=0x0020]
AMD-Vi: Event logged [IO_PAGE_FAULT device=00:11.0 domain=0x0004 address=0x00...
Status: CLOSED EOL
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
22
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-22 18:02 EDT by bgzl
Modified: 2016-12-27 03:48 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-19 15:20:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description bgzl 2015-10-22 18:02:53 EDT
With latest kernel update 4.2.3-200.fc22.x86_64 machine fails to boot with message:

AMD-Vi: Event logged [IO_PAGE_FAULT device=00:11.0 domain=0x0004 address=0x0000000000000000 flags=0x0020]

Relevant info from the same machine/installation with running non-problematic kernel 4.1.10-200.fc22.x86_64 :

[root@localhost ~]# lspci -v -s 00:11.0
00:11.0 SATA controller: Advanced Micro Devices, Inc. [AMD] FCH SATA Controller [AHCI mode] (rev 40) (prog-if 01 [AHCI 1.0])
	Subsystem: ASRock Incorporation Device 7801
	Flags: bus master, 66MHz, medium devsel, latency 32, IRQ 25
	I/O ports at f040 [size=8]
	I/O ports at f030 [size=4]
	I/O ports at f020 [size=8]
	I/O ports at f010 [size=4]
	I/O ports at f000 [size=16]
	Memory at fe109000 (32-bit, non-prefetchable) [size=2K]
	Capabilities: [50] MSI: Enable+ Count=8/8 Maskable- 64bit+
	Capabilities: [70] SATA HBA v1.0
	Kernel driver in use: ahci

[root@localhost ~]# head -n7 /proc/cpuinfo
processor	: 0
vendor_id	: AuthenticAMD
cpu family	: 21
model		: 16
model name	: AMD Athlon(tm) X4 740 Quad Core Processor
stepping	: 1
microcode	: 0x6001119
Comment 1 E Pala 2015-11-06 09:30:32 EST
Same bug? 

https://bugzilla.redhat.com/show_bug.cgi?id=1274422

The latest kernel 4.2.5-201 also has this problem for me.
Comment 2 bgzl 2015-11-08 04:31:30 EST
(In reply to E Pala from comment #1)
> Same bug? 
> 
> https://bugzilla.redhat.com/show_bug.cgi?id=1274422
> 
> The latest kernel 4.2.5-201 also has this problem for me.
Yes, the problem persists with latest kernel, 4.2.5-201.fc22.x86_64, same error pops up. If you can live without IOMMU functionality you can disable it completely from BIOS, which I did, then it boots without problems. Or try with iommu=off kernel option. Also there is iommu=soft for software IOMMU emulation. And there are some specific AMD IOMMU kernel options which I haven't tried yet.
Comment 3 Gordon Kaltofen 2015-12-01 11:10:59 EST
Hi first,

for your interest: We have a bug posted on bugzilla.kernel.org - Bug 108711 (https://bugzilla.kernel.org/show_bug.cgi?id=108711).

We believe in a problem in the kernel itself, because we tested with different distributions (Ubuntu 15.10, Fedora 23, Proxmox VE 4.0). We test the kernel 4.2.2 to 4.2.3 until now.

The use a slightly different hardware, but with identical components affected - AMD-Vi (IOMMU) in combination with Chipset AMD FCH SATA Controller.

Our hardware:
- Mainboard: Supermicro H8SGL-F
- CPU: AMD Opteron 6272 (16 Cores)

Our workaround is currently also the deactivation of IOMMU in the BIOS in combination with "amd_iommu = off" kernel option. This can of course be a permanent solution.

Please support us in the escalation of the bug at kernel.org.

Thx.
Comment 4 Fedora End Of Life 2016-07-19 15:20:47 EDT
Fedora 22 changed to end-of-life (EOL) status on 2016-07-19. Fedora 22 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.