Bug 1274535 - Copy and paste of a table from a pdf file to a text file produces a new line at each column instead of only at each line break
Copy and paste of a table from a pdf file to a text file produces a new line...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-22 18:50 EDT by Peter H. Jones
Modified: 2015-11-09 08:19 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-09 08:19:12 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter H. Jones 2015-10-22 18:50:12 EDT
Description of problem:
I tried to copy and paste a table in a PDF file to a text file. Each column break and each new row produced a new line in the text file, using vi.

Version-Release number of selected component (if applicable):
firefox-41.0.2

How reproducible:
Every time

Steps to Reproduce:
1. Access the PDF at http://www.hamiltonbeach.ca/media/contact/Service_Centres_Canada.pdf .
2. Select All and Copy.
3. Paste to a vi editing session.

Actual results:
Each column break and each line break show as a line break when pasting.

Expected results:
Column breaks should paste as tabs, line breaks as newlines, and page breaks (none in this example) as form-feeds.

Additional info:

Downloading and using evince to to generate the copy caused the copy to run down each columen.

I dndn't try using libreoffice to read the PDF. Maybe that would be better. But I would really like to avoid having do download a whole potentially-large file to extract just a small portion

Perhaps there's an firefox add-on or an attachment to help with this problem.
Comment 1 Jan Horak 2015-11-09 08:19:12 EST
I'm afraid that this particular pdf document is not well structured, you can try to use Adobe Reader to obtain the correct table. I've tried libreoffice and evince and also have no success (even worse results).

Note You need to log in before you can comment on or make changes to this bug.