Bug 127455 - using dbiRaw in backend
using dbiRaw in backend
Status: CLOSED WONTFIX
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Backend (Show other bugs)
rhn350
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mihai Ibanescu
Red Hat Satellite QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-08 10:38 EDT by Ryan Bloom
Modified: 2008-04-21 11:41 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-21 11:41:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ryan Bloom 2004-07-08 10:38:44 EDT
Exception Handler Information
Traceback (innermost last):
  File "/usr/share/rhn/satellite_exporter/satexport.py", line 81, in
_wrapper
    ret = function(req)
  File "/usr/share/rhn/satellite_exporter/satexport.py", line 144, in
_handler
    result = apply(f, params)
  File "/usr/share/rhn/satellite_exporter/handlers/auth_dumper.py",
line 71, in channels
    return self.dump_channels(channel_labels=channel_labels)
  File "/usr/share/rhn/satellite_exporter/exporter/dumper.py", line
249, in dump_channels
    dumper.dump()
  File "/usr/share/rhn/satellite_tools/exporter/exportLib.py", line
73, in dump
    self.timer(6, "dump_subelement", self.dump_subelement, data)
  File "/usr/share/rhn/satellite_tools/exporter/exportLib.py", line
39, in timer    result = apply(function, args, kwargs)
  File "/usr/share/rhn/satellite_tools/exporter/exportLib.py", line
82, in dump_subelement
    data.dump()
  File "/usr/share/rhn/satellite_tools/exporter/exportLib.py", line
73, in dump
    self.timer(6, "dump_subelement", self.dump_subelement, data)
  File "/usr/share/rhn/satellite_tools/exporter/exportLib.py", line
39, in timer    result = apply(function, args, kwargs)
  File "/usr/share/rhn/satellite_exporter/exporter/dumper.py", line
595, in dump_subelement
    self.cache_set(params, s.getvalue())
  File "/usr/share/rhn/satellite_exporter/exporter/dumper.py", line
569, in cache_set
    compressed=1)
  File "/usr/share/rhn/server/rhnDatabaseCache.py", line 237, in set
    params['val_%s' % i] = rhnSQL.dbiRaw(val[start:end])
AttributeError: dbiRaw
Comment 1 Mihai Ibanescu 2004-07-08 15:01:13 EDT
Fixed in HEAD. However, you should set use_database_cache = 0 in
rhn.conf since the database caching is kind of ugly.

Note You need to log in before you can comment on or make changes to this bug.