Bug 127458 - insmod.static is too big.
insmod.static is too big.
Status: CLOSED DEFERRED
Product: Red Hat Raw Hide
Classification: Retired
Component: modutils (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-08 11:03 EDT by Maxim Dziumanenko
Modified: 2014-03-16 22:46 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-08 12:00:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Maxim Dziumanenko 2004-07-08 11:03:56 EDT
Description of problem:
insmod.static is about 575kb long. 
Static insmod compiled with dietlibc is about 93kb long. 

With dietlibc compiled insmod.static my initrd image has smaller on
250kb. 
Now I can create boot floppy, that was impossible before because of
excess of restriction in 1440kb.
 

Version-Release number of selected component (if applicable):
modutils-2.4.26-16

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Maxim Dziumanenko 2004-07-08 11:29:58 EDT
Hmm. This is because I have rebuilt package. 
RedHat binary package really compiled with dietlibc, but it lacks
BuildRequires: dietlibs

Comment 2 Bill Nottingham 2004-07-08 12:00:05 EDT
Architecture-specific buildprereqs really don't work too well; that's
why it's not there.

Note You need to log in before you can comment on or make changes to this bug.