Bug 1274605 - [userinterface_public_456]Should prompt proper info on web console when pod has no log to show.
[userinterface_public_456]Should prompt proper info on web console when pod h...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Management Console (Show other bugs)
3.x
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: bpeterse
yapei
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-23 02:37 EDT by Yanping Zhang
Modified: 2016-09-19 09:53 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-09-19 09:53:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yanping Zhang 2015-10-23 02:37:58 EDT
Description of problem:
Check pod's log on web console, when there is no log for the pod, after the spinning icon disappears in the black box , user can only see "the status:running" and "connection closed reconnect" info. This would make user confused, they will think the logs can not be seen due to closed connection and would try again and again. It's better to show info such as "There is no log for the pod".

Version-Release number of selected component (if applicable):
openshift v1.0.6-876-gf453941-dirty
kubernetes v1.2.0-alpha.1-1107-g4c8e6f4
etcd 2.1.2


How reproducible:
Always

Steps to Reproduce:
1.Create a pod, when pod is running, check there is no log for the pod.
$ oc create -f origin/examples/project-quota/pod-with-resources.yaml in pro1
$ oc logs pod-with-resources -n pro1
2.Login on web console, check the logs of the pod.
3.

Actual results:
1.There is no log displayed.
2.There is no log displayed, after the spinning icon disappears in the black box , user can only see "the status:running" and "connection closed reconnect" info. 

Expected results:
2.It's better to show info such as "There is no log for the pod".


Additional info:
Comment 1 Jessica Forrester 2016-06-10 09:26:19 EDT
this got fixed in origin
Comment 2 Yanping Zhang 2016-06-11 22:34:47 EDT
Checked on origin:
openshift v1.3.0-alpha.1-251-ga19279f
kubernetes v1.3.0-alpha.1-331-g0522e63
etcd 2.3.0

When there is no log for pod's container, check the pod's log on web console, it will display info now:
  "Logs are not available.
The logs are no longer available or could not be loaded."

The bug has been fixed, so move it to Verified.

Note You need to log in before you can comment on or make changes to this bug.