Bug 127463 - vi is too "featurefull"
vi is too "featurefull"
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: vim (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Karsten Hopp
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-08 12:09 EDT by seph
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-21 10:59:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description seph 2004-07-08 12:09:13 EDT
Description of problem:

"vi" is an alias to vim. The vim with the shipped configuration is
very very different than vi. I frequently find that this very
inconvient, as I use vi to edit system configs. vim's autoindent and
linebreak are exactly wrong almost all of the time. Please fix this.
Version-Release number of selected component (if applicable):

Some possible fixes include:

  shipping nvi as vi, instead of vim.

  changing the vim defaults not to set nocompatable or ai

  not aliasing vi to vim, since vim-minimal is also installed.

see also #127462
Comment 1 Karsten Hopp 2004-07-21 10:07:40 EDT
closing as 'wontfix'. If someone installs vim-enhanced, we can 
safely assume that the full featured version is what the user wants. 
There are a few workarounds for you:   
- put an unalias vi in your .bashrc/.profile 
- remove /etc/profile.d/vim.* for systemwide changes 
- run '/bin/vi' if you want to run the minimal version, 'vi' if you  
  want the full version. 
Comment 2 seph 2004-07-21 10:53:38 EDT
> If someone installs vim-enhanced

That's exactly my point. This behavior is an unreasonable default. 
Comment 3 Karsten Hopp 2004-07-21 10:59:52 EDT
reopening the report won't change my mind. 
Comment 4 seph 2004-07-21 11:39:11 EDT
of course. it was the additional comment. I wasn't sure you'd see if
if I didn't reopen.
Comment 5 Kostas Georgiou 2004-07-28 09:21:34 EDT
In a system with hundreds of users just because i installed vim-enhanced doesn't mean 
that all users want to use it. Actually i had a few users complaining about it. 

Is it easy to move /etc/profile.d/vim* to another package (vim-as-vi/whatever) from vim-
enhanced ? This way it will be easy for the administrator to remove the alias if it's not 
wanted.

(I have the same problem with bash-completion as well, some people love it and some 
hate it)

Note You need to log in before you can comment on or make changes to this bug.