Bug 127466 - hang after clicking ok 'Display settings changed' dialog
hang after clicking ok 'Display settings changed' dialog
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: XFree86 (Show other bugs)
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2004-07-08 12:45 EDT by Geoff Gustafson
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-07-11 09:15:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Geoff Gustafson 2004-07-08 12:45:33 EDT
Description of problem:
Testing U3 on an EM64T box, nVidia Quadro FX 330 unknown, using VESA.

Starting r-c-x from text mode after fresh install of U3/x86_64, dialog
comes up, appears completely operational. After pressing OK on main
dialog, "Display settings changed" dialog appears. Pressing OK on that
dialog freezes the system. Cannot do Ctrl-Alt-F1, Ctrl-Alt-Bksp,
Ctrl-Alt-Del -- sometimes keyboard lights will still toggle, sometimes

First time, I set 1280x1024, Millions of colors, Dell 1800FP
(digital), froze - I left it up for say 10 min, then rebooted. After
reboot, startx did work with those settings set properly.

I tried changing fewer settings, still hung. I tried just running it
and immediately pressing OK - same thing.

After rebooting and running startx, comes up, then Ctrl-Alt-Bksp gives
same behavior - so I'm assuming it's an X shutdown problem, not r-c-x.

Even if keyboard lights don't toggle, Ctrl-Alt-Del may work -- beeps
and then 20 sec later reboots (presumably delay from nicely shutting
down services).

Ctrl-Alt-F1 doesn't work from within X, hangs similarly.

Logout from Red Hat menu hangs similarly.

Version-Release number of selected component (if applicable):

How reproducible:
Every time on this EM64T box at least.

Steps to Reproduce:
1. Start X.
2. Ctrl-Alt-Bksp.

Actual results:

Expected results:
Shutdown X; return to console terminal.

Additional info:
Will try again with new 0707 build (this was 0705.2)
Will try installing nVidia driver, see what happens
Comment 1 Geoff Gustafson 2004-07-08 14:53:42 EDT
This does NOT happen with the 0707 build. Was it a known bug or dup?
Comment 3 Mike A. Harris 2004-07-11 09:15:29 EDT
Nothing changed in X in this time, so if it is working for you now,
it must have been a kernel bug, or hardware or configuration issue.

Closing as "NOTABUG".

Note You need to log in before you can comment on or make changes to this bug.