Bug 1274680 - [userinterface_public_525]There is no number shown in the circle icon of metrics chart on IE11
Summary: [userinterface_public_525]There is no number shown in the circle icon of metr...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OKD
Classification: Red Hat
Component: Management Console
Version: 3.x
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: ---
Assignee: Samuel Padgett
QA Contact: Yanping Zhang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-10-23 10:52 UTC by Yanping Zhang
Modified: 2015-11-23 21:17 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-11-23 21:17:24 UTC
Target Upstream Version:


Attachments (Terms of Use)
num-in-icon (315.30 KB, image/png)
2015-10-23 10:55 UTC, Yanping Zhang
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1273704 0 medium CLOSED [userinterface_public_543]Could not see replica numbers in the chart on IE11 and Safari of IPad/Iphone 2021-02-22 00:41:40 UTC

Internal Links: 1273704

Description Yanping Zhang 2015-10-23 10:52:40 UTC
Description of problem:
Create pod with cpu/memory request/limits set. When view the pod metrics on IE11, there is no number shown in the circle icon of metrics chart. There is number shown on other browsers, such as Firefox41/Chrome47/Safari9.

Version-Release number of selected component (if applicable):
IE11
openshift v1.0.6-880-g5f33e54
kubernetes v1.2.0-alpha.1-1107-g4c8e6f4
etcd 2.1.2

How reproducible:
Always


Steps to Reproduce:
1.Create pod with cpu/memory request/limits set.
$oc create -f origin/examples/project-quota/application-template-with-resources.json -n pro1
$oc new-app ruby-helloworld-sample-with-resources -n pro1
2.When pods is running, view pod metrics on IE11.
3.

Actual results:
2. There is no number shown in the circle icon of metrics chart. Refer to attachment.

Expected results:
3.Number should be shown in the circle icon of metrics chart

Additional info:

Comment 1 Yanping Zhang 2015-10-23 10:55:26 UTC
Created attachment 1085814 [details]
num-in-icon

Comment 2 Samuel Padgett 2015-10-23 12:02:01 UTC
Same root cause as https://bugzilla.redhat.com/show_bug.cgi?id=1273704

This is a problem in angular-patternfly and might need an upstream fix. You can see the issue by opening this page in IE:

http://angular-patternfly.rhcloud.com/#/api/patternfly.charts.directive:pfDonutPctChart

Comment 3 Samuel Padgett 2015-10-23 19:36:06 UTC
Upstream pull request:

https://github.com/patternfly/angular-patternfly/pull/135

Comment 4 Samuel Padgett 2015-10-26 18:42:32 UTC
Upstream angular-patternfly fix is merged. Waiting for a release to pull in the fix for origin.

Comment 5 Samuel Padgett 2015-10-26 20:13:09 UTC
Origin pull request:

https://github.com/openshift/origin/pull/5406

Comment 6 Yanping Zhang 2015-10-27 04:14:31 UTC
Tested on latest origin code.
openshift v1.0.6-964-g814c05e
kubernetes v1.2.0-alpha.1-1107-g4c8e6f4
etcd 2.1.2

Setup metrics and check pod metrics on IE11, there is number shown correctly in the circle icon now.

The issue has been fixed, so move the bug to Verified.


Note You need to log in before you can comment on or make changes to this bug.