Bug 127472 - number doesn't work rhnSatelliteInfo.version
number doesn't work rhnSatelliteInfo.version
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Other (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Clifford Perry
wes hayutin
:
Depends On:
Blocks: 472497
  Show dependency treegraph
 
Reported: 2004-07-08 14:43 EDT by Ryan Bloom
Modified: 2009-09-10 14:24 EDT (History)
4 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 14:24:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ryan Bloom 2004-07-08 14:43:34 EDT
Using a number column doesn't work, because we are trying to store a
verison.  We should have used a evr, like Peter wanted.
Comment 1 Peter Jones 2004-07-08 14:55:23 EDT
Thanks, on dev now.
Comment 4 wes hayutin 2009-01-27 12:27:36 EST
client for 'http://rlx-2-04.rhndev.redhat.com/rpc/api' - created
logged in (admin/dog8code), token: '85x532989762d36911f5c4bc971f7a50ea1'
Version =5.3.0
Comment 6 wes hayutin 2009-09-03 17:02:42 EDT
run a script to execute the rhnSatelliteInfo.version api
make sure the version is correct..
Comment 7 John Sefler 2009-09-04 10:43:24 EDT
Verified on staged (Satellite-5.3.0-RHEL5-re20090724.0) with updates from Aug 20, 2009

moving to RELEASE_PENDING

After 5 years, it appears that the api call has changed from rhnSatelliteInfo.version to api.systemVersion()


[jsefler@jsefler api]$ cat api_systemVersion.py
#!/usr/bin/env python

import xmlrpclib

u = 'admin'
p = 'redhat'

url = 'http://rhndev1.z900.redhat.com./rpc/api'

server = xmlrpclib.Server(url,verbose=0)

try:
 session = server.auth.login(u,p)
 version = server.api.systemVersion()
 print "api.systemVersion=%s" % (version)
except(xmlrpclib.Fault), f:
 print "ERROR: an Error was encountered!\n", f
 exit(-1)

[jsefler@jsefler api]$ ./api_systemVersion.py
api.systemVersion=5.3.0
Comment 8 Brandon Perkins 2009-09-10 14:24:04 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.