Bug 1274732 - WARNING: kernel version inconsistency between vmlinux and live memory
WARNING: kernel version inconsistency between vmlinux and live memory
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: crash (Show other bugs)
23
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: Dave Anderson
Fedora Extras Quality Assurance
:
Depends On: 1272061
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-23 09:08 EDT by Dave Anderson
Modified: 2015-10-31 22:29 EDT (History)
3 users (show)

See Also:
Fixed In Version: crash-7.1.3-1.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1272061
Environment:
Last Closed: 2015-10-31 22:29:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Anderson 2015-10-23 09:08:34 EDT
+++ This bug was initially created as a clone of Bug #1272061 +++

Description of problem:

kernel: 4.3.0-rc3+ / 4.3.0-rc5+
crash-7.1.0-1.fc22.x86_64


# crash

crash 7.1.0-1.fc22
Copyright (C) 2002-2014  Red Hat, Inc.
Copyright (C) 2004, 2005, 2006, 2010  IBM Corporation
Copyright (C) 1999-2006  Hewlett-Packard Co
Copyright (C) 2005, 2006, 2011, 2012  Fujitsu Limited
Copyright (C) 2006, 2007  VA Linux Systems Japan K.K.
Copyright (C) 2005, 2011  NEC Corporation
Copyright (C) 1999, 2002, 2007  Silicon Graphics, Inc.
Copyright (C) 1999, 2000, 2001, 2002  Mission Critical Linux, Inc.
This program is free software, covered by the GNU General Public License,
and you are welcome to change it and/or distribute copies of it under
certain conditions.  Enter "help copying" to see the conditions.
This program has absolutely no warranty.  Enter "help warranty" for details.
 
GNU gdb (GDB) 7.6
Copyright (C) 2013 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-unknown-linux-gnu"...

WARNING: kernels compiled by different gcc versions:
  /lib/modules/4.3.0-rc3+/build/vmlinux: (unknown)
  live system kernel: 5.1.1

WARNING: kernel version inconsistency between vmlinux and live memory

crash: incompatible arguments: 
   /lib/modules/4.3.0-rc3+/build/vmlinux is not SMP -- live system is SMP
[...]


Updating to crash 7.1.3 resolves the issue.

--- Additional comment from Dave Anderson on 2015-10-15 09:34:09 EDT ---

No surprise there.  Since Fedora doesn't have a consistent kernel,
I can go through the update procedure today, and tomorrow's kernel
can break it again.  Using the rawhide version is always preferable,
even if the released version still works.

--- Additional comment from Dave Anderson on 2015-10-15 11:30:36 EDT ---

I built an f22 package, but I can't get fedpkg update to work:

$ fedpkg update
Creating a new update for  crash-7.1.3-1.fc22 
Password for crash: 
Creating a new update for  crash-7.1.3-1.fc22 
ServerError(https://admin.fedoraproject.org/updates/save, 404, Not Found)
Traceback (most recent call last):
  File "/usr/bin/bodhi", line 217, in main
    data = bodhi.save(**update_args)
  File "/usr/lib/python2.7/site-packages/fedora/client/bodhi.py", line 111, in save
    'bugs': bugs,
  File "/usr/lib/python2.7/site-packages/fedora/client/baseclient.py", line 344, in send_request
    auth_params=auth_params, retries=retries)
  File "/usr/lib/python2.7/site-packages/fedora/client/proxyclient.py", line 376, in send_request
    raise ServerError(url, http_status, msg)
ServerError: ServerError(https://admin.fedoraproject.org/updates/save, 404, Not Found)
Could not generate update request: Command 'bodhi --new --release f22 --file bodhi.template crash-7.1.3-1.fc22 --username crash' returned non-zero exit status 255
$

--- Additional comment from Fedora Update System on 2015-10-15 11:36:31 EDT ---

crash-7.1.3-1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-b9c85dc537

--- Additional comment from Dave Anderson on 2015-10-15 11:40:05 EDT ---

The web interface worked...

--- Additional comment from Fedora Update System on 2015-10-16 04:51:07 EDT ---

crash-7.1.3-1.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update crash'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-b9c85dc537
Comment 1 Dave Anderson 2015-10-23 09:11:25 EDT
The BZ from which this BZ was cloned is for f22, which failed the push
operation because of this:

============================================================
crash-7.1.3-1.fc22 into f22-updates
============================================================
[ OK ] f21
        Latest package:         crash-7.0.8-1.fc21
[ OK ] f21-updates
        Latest package:         None
[ OK ] f22
        Latest package:         crash-7.1.0-1.fc22
[--->] f22-updates
        Proposed package:       crash-7.1.3-1.fc22
[FAIL] f23 + f23-updates
        Latest package:         crash-7.1.2-1.fc23
        Latest pending package: None
        Error: Condition not satisfied: crash-7.1.3-1.fc22 <= crash-7.1.2-1.fc23
        Error: Proposed package version must be lesser than or equal to the latest (pending) package version.
[ OK ] f24
        Latest package:         crash-7.1.3-1.fc24
        Latest pending package: None
RESULT: FAILED

SUMMARY: 1 FAILED
Comment 2 Fedora Update System 2015-10-23 09:49:28 EDT
crash-7.1.3-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-81f4c632d7
Comment 3 Fedora Update System 2015-10-26 22:20:25 EDT
crash-7.1.3-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update crash'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-81f4c632d7
Comment 4 Fedora Update System 2015-10-31 22:29:17 EDT
crash-7.1.3-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.