Bug 1274850 - BigApp: NullPointerException
BigApp: NullPointerException
Status: CLOSED NOTABUG
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: Form Modeler (Show other bugs)
6.2.0
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: Pere Fernàndez
Pavel Kralik
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-23 12:14 EDT by Pavel Kralik
Modified: 2015-11-13 11:54 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-13 11:54:08 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Server log BPMS 6.2.0.ER4 with BigApp (306.61 KB, text/plain)
2015-10-23 12:14 EDT, Pavel Kralik
no flags Details
Form Modeler error caused by BigApp - catalina.out (336.58 KB, text/plain)
2015-10-29 05:45 EDT, Pavel Kralik
no flags Details
BPMS 6.2.0.ER5 on EAP 6.4.4 server.log (231.53 KB, text/plain)
2015-11-04 11:57 EST, Pavel Kralik
no flags Details

  None (edit)
Description Pavel Kralik 2015-10-23 12:14:43 EDT
Created attachment 1085865 [details]
Server log BPMS 6.2.0.ER4 with BigApp

Description of problem:
NullPointerException when opening Form Definitions.

server.log:
18:04:58,061 ERROR [org.jbpm.formModeler.components.editor.FieldButtonsFormatter] (http-/0.0.0.0:8080-1) Error: : java.lang.NullPointerException
	at org.jbpm.formModeler.components.editor.WysiwygFormEditor.getCurrentForm(WysiwygFormEditor.java:179) [jbpm-form-modeler-form-editor-6.3.0.Final-redhat-2.jar:6.3.0.Final-redhat-2]


Version-Release number of selected component (if applicable):
BPMS 6.2.0.ER4

How reproducible:
Always

Steps to Reproduce:
1. Deploy bigapp
2. Go to Form definitions and open each.

Actual results:
NullPointerException in server.log

Expected results:
No errors

Additional info:
Comment 2 Pere Fernàndez 2015-10-28 08:33:40 EDT
I tried to reproduce it without luck using in EAP, tomcat & hosted mode (master & 6.3.x). Is there any other error message in the log? Maybe it is caused by another error.
Comment 3 Pavel Kralik 2015-10-29 05:43:17 EDT
I get the error on EWS2/3 too. Attaching catalina.out. Maybe it helps.
Comment 4 Pavel Kralik 2015-10-29 05:45 EDT
Created attachment 1087435 [details]
Form Modeler error caused by BigApp - catalina.out
Comment 5 Pavel Kralik 2015-11-04 11:56:51 EST
The bug reproduced in BPMS 6.2.0.ER5 with EAP. Attaching server log.
Comment 6 Pavel Kralik 2015-11-04 11:57 EST
Created attachment 1089770 [details]
BPMS 6.2.0.ER5 on EAP 6.4.4 server.log
Comment 7 Pere Fernàndez 2015-11-13 11:54:08 EST
This is a rendering error caused by a Timeout error on the test.

This timeout makes the test fail and it forces to refresh the app while a form is being rendered causing this NPE.

Note You need to log in before you can comment on or make changes to this bug.