Bug 1274874 - katello-disconnected setup --oauth-key=katello --oauth-secret=<...>: in `block in <module:StrongParameters>': undefined method `rescue_from' for ActionController::Base:Class (NoMethodError)
katello-disconnected setup --oauth-key=katello --oauth-secret=<...>: in `bloc...
Status: CLOSED DUPLICATE of bug 1274606
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Inter Satellite Sync (Show other bugs)
Nightly
Unspecified Unspecified
unspecified Severity medium (vote)
: Unspecified
: --
Assigned To: satellite6-bugs
Katello QA List
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-23 14:38 EDT by Jan Hutař
Modified: 2015-10-30 09:39 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-30 09:39:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Hutař 2015-10-23 14:38:59 EDT
Description of problem:
katello-disconected setup fails


Version-Release number of selected component (if applicable):
Satellite-6.1.0-RHEL-6-20151016.0-x86_64


How reproducible:
always


Steps to Reproduce:
1. On clean RHEL 6.7 register via RHSM and configure required repos
2. Add Satellite-6.1.0-RHEL-6-20151016.0-x86_64 repo
3. # yum -y install python-qpid-qmf python-qpid \
                    qpid-cpp-server-store katello-utils
4. # cat /etc/pulp/server.conf
   [oauth]
   enabled: true
   oauth_key: katello
   oauth_secret: 00000000000000000000000000000000
5. # sed -i 's/^auth\s*=.*/auth=no/' /etc/qpid/qpidd.conf
6. # katello-disconnected setup --oauth-key=katello --oauth-secret=00000000000000000000000000000000


Actual results:
/opt/rh/ruby193/root/usr/share/gems/gems/strong_parameters-0.2.1/lib/action_controller/parameters.rb:239:in `block in <module:StrongParameters>': undefined method `rescue_from' for ActionController::Base:Class (NoMethodError)
	from /opt/rh/ruby193/root/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/concern.rb:119:in `class_eval'
	from /opt/rh/ruby193/root/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/concern.rb:119:in `append_features'
	from /opt/rh/ruby193/root/usr/share/gems/gems/strong_parameters-0.2.1/lib/action_controller/parameters.rb:254:in `include'
	from /opt/rh/ruby193/root/usr/share/gems/gems/strong_parameters-0.2.1/lib/action_controller/parameters.rb:254:in `<top (required)>'
	from /opt/rh/ruby193/root/usr/share/rubygems/rubygems/custom_require.rb:36:in `require'
	from /opt/rh/ruby193/root/usr/share/rubygems/rubygems/custom_require.rb:36:in `require'
	from /opt/rh/ruby193/root/usr/share/gems/gems/strong_parameters-0.2.1/lib/strong_parameters.rb:1:in `<top (required)>'
	from /opt/rh/ruby193/root/usr/share/rubygems/rubygems/custom_require.rb:36:in `require'
	from /opt/rh/ruby193/root/usr/share/rubygems/rubygems/custom_require.rb:36:in `require'
	from /opt/rh/ruby193/root/usr/share/gems/gems/katello-2.2.0.73/lib/katello.rb:17:in `<top (required)>'
	from /opt/rh/ruby193/root/usr/share/rubygems/rubygems/custom_require.rb:60:in `require'
	from /opt/rh/ruby193/root/usr/share/rubygems/rubygems/custom_require.rb:60:in `rescue in require'
	from /opt/rh/ruby193/root/usr/share/rubygems/rubygems/custom_require.rb:35:in `require'
	from /usr/bin/katello-disconnected:27:in `<main>'
	from caused by: (LoadError) cannot load such file -- katello
	from /opt/rh/ruby193/root/usr/share/rubygems/rubygems/custom_require.rb:36:in `require'
	from /opt/rh/ruby193/root/usr/share/rubygems/rubygems/custom_require.rb:36:in `require'
	from     ... skipped 1 lines


Expected results:
Should work
Comment 2 Brad Buckingham 2015-10-30 09:39:16 EDT

*** This bug has been marked as a duplicate of bug 1274606 ***

Note You need to log in before you can comment on or make changes to this bug.