Bug 1274896 - AttributeError: 'DiskDevice' object has no attribute 'disk'
AttributeError: 'DiskDevice' object has no attribute 'disk'
Status: CLOSED DUPLICATE of bug 1226065
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:bcdcdf1bb618404437f75dc5beb...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-23 15:15 EDT by Tomas Toth
Modified: 2015-10-26 10:42 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-26 10:42:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (423.34 KB, text/plain)
2015-10-23 15:15 EDT, Tomas Toth
no flags Details
File: anaconda.log (20.99 KB, text/plain)
2015-10-23 15:15 EDT, Tomas Toth
no flags Details
File: environ (600 bytes, text/plain)
2015-10-23 15:15 EDT, Tomas Toth
no flags Details
File: journalctl (190.53 KB, text/plain)
2015-10-23 15:15 EDT, Tomas Toth
no flags Details
File: lsblk_output (1.97 KB, text/plain)
2015-10-23 15:15 EDT, Tomas Toth
no flags Details
File: nmcli_dev_list (1.20 KB, text/plain)
2015-10-23 15:15 EDT, Tomas Toth
no flags Details
File: os_info (451 bytes, text/plain)
2015-10-23 15:15 EDT, Tomas Toth
no flags Details
File: program.log (29.90 KB, text/plain)
2015-10-23 15:15 EDT, Tomas Toth
no flags Details
File: storage.log (111.56 KB, text/plain)
2015-10-23 15:15 EDT, Tomas Toth
no flags Details
File: ifcfg.log (2.55 KB, text/plain)
2015-10-23 15:15 EDT, Tomas Toth
no flags Details

  None (edit)
Description Tomas Toth 2015-10-23 15:15:10 EDT
Description of problem:
Trynig to instal F23 RC3 Fedora-Live-KDE-x86_64-23-3.iso as VM in a F21 host.

Version-Release number of selected component:
anaconda-core-23.19.10-1.fc23.x86_64

The following was filed automatically by anaconda:
anaconda 23.19.10-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python3.4/site-packages/blivet/actionlist.py", line 287, in process
    if dep.exists and dep.dependsOn(action.device.disk):
  File "/usr/lib/python3.4/site-packages/blivet/devicetree.py", line 380, in processActions
    callbacks=callbacks)
  File "/usr/lib/python3.4/site-packages/blivet/blivet.py", line 164, in doIt
    self.devicetree.processActions(callbacks=callbacks)
  File "/usr/lib/python3.4/site-packages/blivet/osinstall.py", line 1096, in turnOnFilesystems
    storage.doIt(callbacks)
  File "/usr/lib64/python3.4/site-packages/pyanaconda/install.py", line 195, in doInstall
    turnOnFilesystems(storage, mountOnly=flags.flags.dirInstall, callbacks=callbacks_reg)
  File "/usr/lib64/python3.4/threading.py", line 868, in run
    self._target(*self._args, **self._kwargs)
  File "/usr/lib64/python3.4/site-packages/pyanaconda/threads.py", line 253, in run
    threading.Thread.run(self, *args, **kwargs)
AttributeError: 'DiskDevice' object has no attribute 'disk'

Additional info:
cmdline:        /usr/bin/python3  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=vmlinuz0 initrd=initrd0.img root=live:CDLABEL=Fedora-Live-KDE-x86_64-23-3 rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         4.2.3-300.fc23.x86_64
other involved packages: python3-libs-3.4.3-5.fc23.x86_64, python3-blivet-1.12.8-1.fc23.noarch
product:        Fedora
release:        Fedora release 23 (Twenty Three)
type:           anaconda
version:        23
Comment 1 Tomas Toth 2015-10-23 15:15:16 EDT
Created attachment 1085883 [details]
File: anaconda-tb
Comment 2 Tomas Toth 2015-10-23 15:15:18 EDT
Created attachment 1085884 [details]
File: anaconda.log
Comment 3 Tomas Toth 2015-10-23 15:15:19 EDT
Created attachment 1085885 [details]
File: environ
Comment 4 Tomas Toth 2015-10-23 15:15:22 EDT
Created attachment 1085886 [details]
File: journalctl
Comment 5 Tomas Toth 2015-10-23 15:15:24 EDT
Created attachment 1085887 [details]
File: lsblk_output
Comment 6 Tomas Toth 2015-10-23 15:15:25 EDT
Created attachment 1085888 [details]
File: nmcli_dev_list
Comment 7 Tomas Toth 2015-10-23 15:15:27 EDT
Created attachment 1085889 [details]
File: os_info
Comment 8 Tomas Toth 2015-10-23 15:15:29 EDT
Created attachment 1085890 [details]
File: program.log
Comment 9 Tomas Toth 2015-10-23 15:15:31 EDT
Created attachment 1085891 [details]
File: storage.log
Comment 10 Tomas Toth 2015-10-23 15:15:33 EDT
Created attachment 1085892 [details]
File: ifcfg.log
Comment 11 Tomas Toth 2015-10-23 15:30:53 EDT
Possible duplicate of
bug 1202058, bug 1219219 and bug 1226065.
Comment 12 David Lehman 2015-10-26 10:42:51 EDT

*** This bug has been marked as a duplicate of bug 1226065 ***

Note You need to log in before you can comment on or make changes to this bug.