Bug 1274943 - [abrt] webkitgtk4: IPC::Connection::didFailToSendSyncMessage(): WebKitWebProcess killed by SIGSEGV
[abrt] webkitgtk4: IPC::Connection::didFailToSendSyncMessage(): WebKitWebProc...
Status: CLOSED DUPLICATE of bug 1282844
Product: Fedora
Classification: Fedora
Component: webkitgtk4 (Show other bugs)
22
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tomas Popela
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:92f7d62458aa5508c833c42af69...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-23 20:31 EDT by Chen_Min_Chin
Modified: 2016-01-16 08:22 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-16 08:22:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (73.77 KB, text/plain)
2015-10-23 20:31 EDT, Chen_Min_Chin
no flags Details
File: cgroup (190 bytes, text/plain)
2015-10-23 20:31 EDT, Chen_Min_Chin
no flags Details
File: core_backtrace (12.56 KB, text/plain)
2015-10-23 20:31 EDT, Chen_Min_Chin
no flags Details
File: dso_list (13.89 KB, text/plain)
2015-10-23 20:31 EDT, Chen_Min_Chin
no flags Details
File: environ (3.46 KB, text/plain)
2015-10-23 20:31 EDT, Chen_Min_Chin
no flags Details
File: limits (1.29 KB, text/plain)
2015-10-23 20:31 EDT, Chen_Min_Chin
no flags Details
File: maps (101.86 KB, text/plain)
2015-10-23 20:31 EDT, Chen_Min_Chin
no flags Details
File: mountinfo (3.93 KB, text/plain)
2015-10-23 20:31 EDT, Chen_Min_Chin
no flags Details
File: namespaces (85 bytes, text/plain)
2015-10-23 20:31 EDT, Chen_Min_Chin
no flags Details
File: open_fds (1.28 KB, text/plain)
2015-10-23 20:31 EDT, Chen_Min_Chin
no flags Details
File: proc_pid_status (1011 bytes, text/plain)
2015-10-23 20:31 EDT, Chen_Min_Chin
no flags Details
File: var_log_messages (28 bytes, text/plain)
2015-10-23 20:32 EDT, Chen_Min_Chin
no flags Details

  None (edit)
Description Chen_Min_Chin 2015-10-23 20:31:37 EDT
Version-Release number of selected component:
webkitgtk4-2.8.5-2.fc22

Additional info:
reporter:       libreport-2.6.2
backtrace_rating: 4
cmdline:        /usr/libexec/webkit2gtk-4.0/WebKitWebProcess 32
crash_function: IPC::Connection::didFailToSendSyncMessage
executable:     /usr/libexec/webkit2gtk-4.0/WebKitWebProcess
global_pid:     3267
kernel:         4.1.10-200.fc22.x86_64
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #24 IPC::Connection::didFailToSendSyncMessage at /usr/src/debug/webkitgtk-2.8.5/Source/WebKit2/Platform/IPC/Connection.cpp:833
 #25 IPC::Connection::sendSyncMessage at /usr/src/debug/webkitgtk-2.8.5/Source/WebKit2/Platform/IPC/Connection.cpp:521
 #26 IPC::Connection::sendSync<Messages::WebProcessProxy::ShouldTerminate>(Messages::WebProcessProxy::ShouldTerminate&&, Messages::WebProcessProxy::ShouldTerminate::Reply&&, unsigned long, std::chrono::duration<long, std::ratio<1l, 1000l> >, unsigned int) at /usr/src/debug/webkitgtk-2.8.5/Source/WebKit2/Platform/IPC/Connection.h:362
 #27 WebKit::WebProcess::shouldTerminate at /usr/src/debug/webkitgtk-2.8.5/Source/WebKit2/WebProcess/WebProcess.cpp:578
 #28 WebKit::ChildProcess::terminationTimerFired at /usr/src/debug/webkitgtk-2.8.5/Source/WebKit2/Shared/ChildProcess.cpp:145
 #29 WebKit::WebPage::close at /usr/src/debug/webkitgtk-2.8.5/Source/WebKit2/WebProcess/WebPage/WebPage.cpp:1056
 #30 callMemberFunctionImpl<WebKit::WebPage, void (WebKit::WebPage::*)(), std::tuple<> > at /usr/src/debug/webkitgtk-2.8.5/Source/WebKit2/Platform/IPC/HandleMessage.h:16
 #31 callMemberFunction<WebKit::WebPage, void (WebKit::WebPage::*)(), std::tuple<>, std::make_index_sequence<0ul> > at /usr/src/debug/webkitgtk-2.8.5/Source/WebKit2/Platform/IPC/HandleMessage.h:22
 #32 handleMessage<Messages::WebPage::Close, WebKit::WebPage, void (WebKit::WebPage::*)()> at /usr/src/debug/webkitgtk-2.8.5/Source/WebKit2/Platform/IPC/HandleMessage.h:92
 #33 WebKit::WebPage::didReceiveWebPageMessage at /usr/src/debug/webkitgtk-2.8.5/x86_64-redhat-linux-gnu/DerivedSources/WebKit2/WebPageMessageReceiver.cpp:629
Comment 1 Chen_Min_Chin 2015-10-23 20:31:42 EDT
Created attachment 1086021 [details]
File: backtrace
Comment 2 Chen_Min_Chin 2015-10-23 20:31:44 EDT
Created attachment 1086022 [details]
File: cgroup
Comment 3 Chen_Min_Chin 2015-10-23 20:31:45 EDT
Created attachment 1086023 [details]
File: core_backtrace
Comment 4 Chen_Min_Chin 2015-10-23 20:31:47 EDT
Created attachment 1086024 [details]
File: dso_list
Comment 5 Chen_Min_Chin 2015-10-23 20:31:49 EDT
Created attachment 1086025 [details]
File: environ
Comment 6 Chen_Min_Chin 2015-10-23 20:31:50 EDT
Created attachment 1086026 [details]
File: limits
Comment 7 Chen_Min_Chin 2015-10-23 20:31:52 EDT
Created attachment 1086027 [details]
File: maps
Comment 8 Chen_Min_Chin 2015-10-23 20:31:54 EDT
Created attachment 1086028 [details]
File: mountinfo
Comment 9 Chen_Min_Chin 2015-10-23 20:31:56 EDT
Created attachment 1086029 [details]
File: namespaces
Comment 10 Chen_Min_Chin 2015-10-23 20:31:57 EDT
Created attachment 1086030 [details]
File: open_fds
Comment 11 Chen_Min_Chin 2015-10-23 20:31:58 EDT
Created attachment 1086031 [details]
File: proc_pid_status
Comment 12 Chen_Min_Chin 2015-10-23 20:32:00 EDT
Created attachment 1086032 [details]
File: var_log_messages
Comment 13 Michael Catanzaro 2016-01-16 08:22:20 EST

*** This bug has been marked as a duplicate of bug 1282844 ***

Note You need to log in before you can comment on or make changes to this bug.