Bug 1274950 - Missing description of resource units
Missing description of resource units
Status: CLOSED NOTABUG
Product: OpenShift Container Platform
Classification: Red Hat
Component: Documentation (Show other bugs)
3.0.0
Unspecified Unspecified
medium Severity high
: ---
: ---
Assigned To: Thien-Thi Nguyen
Vikram Goyal
Vikram Goyal
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-23 21:43 EDT by Erik M Jacobs
Modified: 2016-08-04 21:27 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-07 11:04:17 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Erik M Jacobs 2015-10-23 21:43:12 EDT
We may want to incorporate something like:

http://kubernetes.io/v1.0/docs/design/resources.html

To explain what cores/cpu actually are. Specifically, the section on kcu/cpu:

http://kubernetes.io/v1.0/docs/design/resources.html#processor-cycles
Comment 2 Thien-Thi Nguyen 2015-10-24 10:50:13 EDT
Related: https://bugzilla.redhat.com/show_bug.cgi?id=1267008
Comment 3 Thien-Thi Nguyen 2015-11-24 12:49:47 EST
(In reply to Erik M Jacobs from comment #0)

> We may want to incorporate something like:
>
> http://kubernetes.io/v1.0/docs/design/resources.html
>
> To explain what cores/cpu actually are. Specifically, the section on kcu/cpu:
>
> http://kubernetes.io/v1.0/docs/design/resources.html#processor-cycles

The "Compute Resources" chapter of the Developer Guide:

 https://access.redhat.com/documentation/en/openshift-enterprise/version-3.1/developer-guide/#compute-resource-units

seems to partially satisfy this BZ.  (It's still missing some mention of "kcu".)  Do we still want to include "kcu" info?  What about the current text -- is it sufficient?
Comment 4 Erik M Jacobs 2015-11-24 12:52:04 EST
The question regarding KCU would need to be answered by engineering. Part of the reason KCU exists is because of CPU scaling, but I'm not sure we're exposing that to customers.

I would say that most of the text is sufficient but someone should probably decide whether or not we need to talk about KCU.
Comment 5 Thien-Thi Nguyen 2015-11-24 15:09:53 EST
Thanks for the redirect.  Setting needinfo to the the author (AFAICT) of the Compute Resources chapter, who is in engineering.  (Derek, please see comments 3 and 4.)
Comment 6 Derek Carr 2015-12-07 09:37:00 EST
I think the current text is sufficient.

Until such time that we look to support normalization of compute across the cluster with any more intelligence, just describing compute in terms of fractional cores is the clearest thing that we can do.  I think anything else introduces confusion.
Comment 7 Thien-Thi Nguyen 2015-12-07 11:04:17 EST
Moving to CLOSED NOTABUG.

Note You need to log in before you can comment on or make changes to this bug.