Bug 1274961 - [Docs] Bad port (most likely missing protocol) in 6.1 Documentation firewall configuration
[Docs] Bad port (most likely missing protocol) in 6.1 Documentation firewall ...
Status: CLOSED NOTABUG
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Docs Install Guide (Show other bugs)
6.1.1
Unspecified Unspecified
medium Severity medium (vote)
: Unspecified
: 6.1
Assigned To: Peter Ondrejka
David O'Brien
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-24 01:57 EDT by Pradeep Kumar Surisetty
Modified: 2015-11-24 03:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-24 03:11:04 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pradeep Kumar Surisetty 2015-10-24 01:57:43 EDT
Description of problem:


In Below documentation needs a minor change while configuring firewall. 

https://access.redhat.com/documentation/en-US/Red_Hat_Satellite/6.1/html/Installation_Guide/sect-Red_Hat_Satellite-Installation_Guide-Prerequisites.html

Section: On a Red Hat Enterprise Linux 7 Satellite, execute as root:

------
Actual:

firewall-cmd --permanent --add-port="53/udp" --add-port="53/tcp" \
 --add-port="67/udp" --add-port="68/udp" \
 --add-port="69/udp" --add-port="80/tcp" \
 --add-port="443/tcp"--add-port="5647/tcp" \
 --add-port="8140/tcp" \
&& firewall-cmd --reload

Need to change to:


firewall-cmd --permanent --add-port="53/udp" --add-port="53/tcp" \
 --add-port="67/udp" --add-port="68/udp" \
 --add-port="69/udp" --add-port="80/tcp" \
 --add-port="443/tcp" --add-port="5647/tcp" \
 --add-port="8140/tcp" \
&& firewall-cmd --reload

------


Version-Release number of selected component (if applicable):


How reproducible:


root@ip-172-31-49-67: ~ # service firewalld start
Redirecting to /bin/systemctl start  firewalld.service
root@ip-172-31-49-67: ~ # firewall-cmd --permanent --add-port="53/udp" --add-port="53/tcp"  --add-port="67/udp" --add-port="68/udp"  --add-port="69/udp" --add-port="80/tcp"  --add-port="443/tcp"--add-port="5647/tcp"  --add-port="8140/tcp" && firewall-cmd --reload

bad port (most likely missing protocol), correct syntax is portid[-portid]/protocol





Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Andrew Dahms 2015-11-23 05:18:56 EST
Assigning to Peter for review.

Peter - looks like a missing space between the two commands in ' --add-port="443/tcp"--add-port="5647/tcp" \'
Comment 2 Peter Ondrejka 2015-11-24 03:11:04 EST
Hello Pradeep and Andrew,

The firewall section was reorganized in BZ#1221115. The missing space is no longer there.

Cheers

Note You need to log in before you can comment on or make changes to this bug.