Bug 1274970 - [gnome-boxes] dead key when German layout is chosen
[gnome-boxes] dead key when German layout is chosen
Status: CLOSED DUPLICATE of bug 1258023
Product: Fedora
Classification: Fedora
Component: qemu (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Fedora Virtualization Maintainers
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-24 05:51 EDT by Joachim Frieben
Modified: 2016-02-15 16:51 EST (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-15 16:51:44 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of German keyboard layout (43.00 KB, image/png)
2015-10-24 05:51 EDT, Joachim Frieben
no flags Details

  None (edit)
Description Joachim Frieben 2015-10-24 05:51:24 EDT
Created attachment 1086064 [details]
Screenshot of German keyboard layout

Description of problem:
When running Fedora in a virtual machine by means of gnome-boxes and a German keyboard layout is chosen, the key providing the less, greater, and vertical stroke signs (located in the lower left part of the keyboard shown in the attachment) is disabled.

Version-Release number of selected component (if applicable):
gnome-boxes-3.18.1-1.fc23

How reproducible:
Always.

Steps to Reproduce:
1. Run Fedora 21/22/23 in a virtual machine under Fedora 22.
2. Press the key with less, greater, and vertical stroke signs in a virtual console or in some X application.

Actual results:
None

Expected results:
The less, greater, or vertical stroke sign which has been pressed is printed.

Additional info:
No other disabled key has been found to this date.
How reproducible:
Always.

Steps to Reproduce:
1. Run Fedora 21/22/23 in a virtual machine under Fedora 23.
2. Press the key with less, greater, and vertical stroke signs in a virtual console or in some X application.

Actual results:
None

Expected results:
The less, greater, or vertical stroke sign which has been pressed is printed.

Additional info:
Issue was reported for Fedora 22 as bug 1258023 which is still open.
Comment 1 Christophe Fergeau 2015-10-26 05:29:40 EDT
(In reply to Joachim Frieben from comment #0)
> Additional info:
> Issue was reported for Fedora 22 as bug 1258023 which is still open.

And as mentioned in https://bugzilla.redhat.com/show_bug.cgi?id=1258023#c6 , this is caused by the USB keyboard Boxes adds to its VMs.
Comment 2 Joachim Frieben 2015-10-26 11:17:24 EDT
(In reply to Christophe Fergeau from comment #1)
This may be the case, but this bug is still neither fixed in Fedora 22 nor in Fedora 23, the latter approaching final release.
Comment 3 Christophe Fergeau 2015-11-30 10:57:17 EST
The key (102nd keyboard key) properly reaches QEMU, but it then somehow dropped. This can be reproduced with
qemu-system-x86_64 -enable-kvm -display sdl -cdrom /home/teuf/redhat/isos/Fedora-Live-Workstation-i686-21-5.iso -m 2G -usb -device usb-kbd
and does not happen if -usb -device usb-kbd is dropped.
Comment 4 Cole Robinson 2016-02-15 16:51:44 EST

*** This bug has been marked as a duplicate of bug 1258023 ***

Note You need to log in before you can comment on or make changes to this bug.