Bug 1274999 - [abrt] dnf: base.py:127:_add_repo_to_sack:AssertionError: Can not load repo.
[abrt] dnf: base.py:127:_add_repo_to_sack:AssertionError: Can not load repo.
Status: CLOSED DUPLICATE of bug 1250700
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
22
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:f7a6931c08656087835f51a4dcf...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-24 14:42 EDT by Mikhail Yarashevich
Modified: 2015-10-26 09:04 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-26 09:04:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (1.13 KB, text/plain)
2015-10-24 14:42 EDT, Mikhail Yarashevich
no flags Details
File: environ (3.25 KB, text/plain)
2015-10-24 14:42 EDT, Mikhail Yarashevich
no flags Details

  None (edit)
Description Mikhail Yarashevich 2015-10-24 14:42:10 EDT
Version-Release number of selected component:
dnf-1.1.3-1.fc22

Additional info:
reporter:       libreport-2.6.2
cmdline:        /usr/bin/python -OO /usr/bin/dnf check-update
dso_list:       python-dnf-1.1.3-1.fc22.noarch
executable:     /usr/bin/dnf
kernel:         4.2.3-200.fc22.x86_64
runlevel:       N 5
type:           Python
uid:            1000

Truncated backtrace:
base.py:127:_add_repo_to_sack:AssertionError: Can not load repo.

Traceback (most recent call last):
  File "/usr/bin/dnf", line 36, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 198, in user_main
    errcode = main(args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 84, in main
    return _main(base, args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 136, in _main
    cli.run()
  File "/usr/lib/python2.7/site-packages/dnf/cli/cli.py", line 1090, in run
    self._process_demands()
  File "/usr/lib/python2.7/site-packages/dnf/cli/cli.py", line 810, in _process_demands
    load_available_repos=lar)
  File "/usr/lib/python2.7/site-packages/dnf/base.py", line 249, in fill_sack
    self._add_repo_to_sack(r.id)
  File "/usr/lib/python2.7/site-packages/dnf/base.py", line 127, in _add_repo_to_sack
    load_updateinfo=True)
AssertionError: Can not load repo.

Local variables in innermost frame:
repo: <Repo updates>
hrepo: <_hawkey.Repo object at 0x7fe765fdc390>
self: <dnf.cli.cli.BaseCli object at 0x7fe765fd16d0>
name: u'updates'
Comment 1 Mikhail Yarashevich 2015-10-24 14:42:15 EDT
Created attachment 1086119 [details]
File: backtrace
Comment 2 Mikhail Yarashevich 2015-10-24 14:42:17 EDT
Created attachment 1086120 [details]
File: environ
Comment 3 Honza Silhan 2015-10-26 09:04:01 EDT

*** This bug has been marked as a duplicate of bug 1250700 ***

Note You need to log in before you can comment on or make changes to this bug.