Bug 1275052 - [GTK3][Xorg] Context menus on multi-GPU systems get misplaced
[GTK3][Xorg] Context menus on multi-GPU systems get misplaced
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: gtk3 (Show other bugs)
23
Unspecified Linux
unspecified Severity high
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-25 08:52 EDT by bob
Modified: 2016-04-26 12:55 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-26 12:55:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description bob 2015-10-25 08:52:22 EDT
User-Agent:       Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:41.0) Gecko/20100101 Firefox/41.0
Build Identifier: 

I have four monitors, two driven by an HD6950 and the other two driven by the integrated Intel GPU. Context menus on the center two monitors (radeon) appear fine, but a right-click or menu activation on GTK3 windows on the outer monitors either end up with their menus drawn on the nearest edge of the bottom center monitor or the menus are not at all visible.

This bug does not affect GTK2 windows, their context menus are positioned normally.

Reproducible: Always

Steps to Reproduce:
1. Open GTK3 application
2. Move window to monitors driven by the secondary GPU
3. Open context menu
Actual Results:  
Menu positioned on primary GPU monitors, or invisible

Expected Results:  
Context menu appearing at the source of the right click

rpm -q gtk3 
gtk3-3.18.2-1.fc23.x86_64

This is a regression from 3.16 where GTK3 context menus worked fine on my setup.
Comment 1 Paul Black 2015-11-06 05:08:50 EST
I'm seeing the same on a laptop with an external monitor.

Under KDE Fedora 23, Firefox menus and pop-ups usually do not appear (never on the external screen and rarely on the laptop); Eclipse menus and pop-ups always appear on the laptop screen.

There was no such issue on Fedora 22.

Google Chrome is fine but then it appears to be using GTK2 ...
Comment 2 Andy Campbell 2016-04-26 12:19:02 EDT
Possibly an Xorg issue ?

Bug 1320731 - Window menu appears on wrong monitor (Qt applications) 

Downgrading to Xorg the F22 version seems to fix it for Display Link  ( essentially two graphics cards )
Comment 3 bob 2016-04-26 12:55:36 EDT
Sorry, I forgot about this bug. This problem seems to be resolved on F24 alpha.

➜  ~ rpm -q gtk3 xorg-x11-server-Xorg
gtk3-3.20.3-1.fc24.x86_64
xorg-x11-server-Xorg-1.18.3-1.fc24.x86_64

Note You need to log in before you can comment on or make changes to this bug.