Bug 1275054 - Firefox etc. icons no longer packaged
Firefox etc. icons no longer packaged
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: plasma-breeze (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-25 09:03 EDT by Markus S.
Modified: 2015-10-28 20:34 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-26 11:50:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Markus S. 2015-10-25 09:03:48 EDT
Since the Plasma 5.4.2 / KF 5.10 update icons for Firefox and probably everything else from Breeze's trademarked-logos branch <https://github.com/NitruxSA/breeze-icon-theme/tree/trademarked-logos> are no longer available.
Tested under F22.
Comment 1 Rex Dieter 2015-10-26 07:48:02 EDT
I think the name of the branch makes it fairly clear why both upstream (and by extention, fedora downstream) does not (and can not) include these.

What is your expectation ?
Comment 2 Markus S. 2015-10-26 11:26:25 EDT
Upstream and downstream happily provided those icons until now.
Fedora also happily ships the Mozilla's trademarked Firefox icon, just not in Breeze style.
As long as Fedora ships Firefox (and not Debian's IceWeasel), I expect the proper icon to be shipped as long as Red Hat Legal does not forbid it.
Comment 3 Rex Dieter 2015-10-26 11:50:30 EDT
firefox owns the trademark, so they certainly are free to do what they want with it (including shipping it in their source code provided to distributions).

I can only speculate why upstream once included them and now do not, that would be a good question for them.  We can only ship what they provide.
Comment 4 Rex Dieter 2015-10-26 11:51:38 EDT
To be clear, in my prior comment, upstream refers to kde/plasma-breeze upstream.
Comment 5 Markus S. 2015-10-26 12:20:56 EDT
Then revert the last update. It's clearly a regression…
Comment 6 Rex Dieter 2015-10-26 12:44:34 EDT
My speculation: neither kde realized they do not have permission to distribute modified trademark'd icons, so removed them.  My extension, fedora (downstream) cannot freely redistribute them either.

That's why I suggested that you ask them for clarification, if you're still intersted in persuing this.
Comment 7 Kevin Kofler 2015-10-28 20:34:30 EDT
> Upstream and downstream happily provided those icons until now.

And this was a mistake, because it was illegal.

> Fedora also happily ships the Mozilla's trademarked Firefox
> icon, just not in Breeze style.

Which is allowed by the trademark and copyright license of that icon. Modifying it (and "restyling" is modification) is not.

> As long as Fedora ships Firefox (and not Debian's IceWeasel),
> I expect the proper icon to be shipped as long as Red Hat Legal
> does not forbid it.

Unfortunately the Breeze icon is not the "proper" icon in the trademark owner's view.

> Then revert the last update. It's clearly a regression…

We can't. This would reintroduce a fixed legal issue and get us yelled at by Red Hat Legal. The old versions would also have no viable upgrade path.

Note You need to log in before you can comment on or make changes to this bug.