Bug 1275058 - python-request dnf update failed
python-request dnf update failed
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: python-requests (Show other bugs)
22
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Arun S A G
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-25 09:20 EDT by Patrice FERLET
Modified: 2015-10-25 09:26 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-25 09:26:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Patrice FERLET 2015-10-25 09:20:48 EDT
Description of problem:

An error occured when I update package

Version-Release number of selected component (if applicable):

python-requests-2.7.0-7.fc22.noarch

How reproducible:

Always

Steps to Reproduce:

1. sudo dnf update

Actual results:
Last metadata expiration check performed 0:00:00 ago on Sun Oct 25 14:17:05 2015.
Dependencies resolved.
========================================================================================================================================================================
 Package                                      Arch                                Version                                    Repository                            Size
========================================================================================================================================================================
Upgrading:
 python-requests                              noarch                              2.7.0-7.fc22                               updates                              101 k

Transaction Summary
========================================================================================================================================================================
Upgrade  1 Package

Total download size: 101 k
Is this ok [y/N]: y
Downloading Packages:
python-requests-2.7.0-6.fc22_2.7.0-7.fc22.noarch.drpm                                                                                    19 kB/s |  19 kB     00:00    
/usr/lib/python2.7/site-packages/requests/__init__.pyo: No such file or directory
cannot reconstruct rpm from disk files
python-requests-2.7.0-7.fc22.noarch: Delta RPM rebuild failed
python-requests-2.7.0-7.fc22.noarch.rpm                                                                                                 100 kB/s | 101 kB     00:01    
------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Total                                                                                                                                    34 kB/s | 120 kB     00:03     
Delta RPMs reduced 0.1 MB of updates to 0.1 MB (-18.1% saved)
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
  Upgrading   : python-requests-2.7.0-7.fc22.noarch                                                                                                                 1/2 
Error unpacking rpm package python-requests-2.7.0-7.fc22.noarch
Error unpacking rpm package python-requests-2.7.0-7.fc22.noarch
error: unpacking of archive failed on file /usr/lib/python2.7/site-packages/requests/packages/chardet: cpio: rename
python-requests-2.7.0-7.fc22.noarch was supposed to be installed but is not!
  Verifying   : python-requests-2.7.0-7.fc22.noarch                                                                                                                 1/2 
python-requests-2.7.0-6.fc22.noarch was supposed to be removed but is not!
  Verifying   : python-requests-2.7.0-6.fc22.noarch                                                                                                                 2/2 

Failed:
  python-requests.noarch 2.7.0-7.fc22                                                                                                                                   

Complete!

Expected results:

Update complete

Additional info:

I tried to clean cache, and some option as --allowerasing and --best - same result
Comment 1 Patrice FERLET 2015-10-25 09:26:28 EDT
Ok, I found: https://bugzilla.redhat.com/show_bug.cgi?id=1177479#c4 too late. It seems that "pip uninstall requests" fixed the problem. I don't know why, I didn't install anything with pip on the system.

I can close

Note You need to log in before you can comment on or make changes to this bug.