Bug 1275099 - ThinkPad W540 (with nVidia Quadro K1100M) unbootable
ThinkPad W540 (with nVidia Quadro K1100M) unbootable
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
22
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-25 17:31 EDT by Sergei Shtylyov
Modified: 2016-06-13 15:11 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-13 15:11:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sergei Shtylyov 2015-10-25 17:31:05 EDT
Description of problem:

I have ThinkPad W540 and I use the nouveau driver for NVidia Quadro K1100M (the BIOS doesn't seem to allow swithing to the integrated graphics). For me the boot hangs (unless <Esc> is pressed to get the Fedora startup log) since I installed Fedora 20 (3.11.? kernel) and after I upgraded to Fedora 21 and now 22 (kernel v4.2.3-200). Before Fedora 22 the screen typically gets flooded with the following message:

nouveau E[  PFIFO[0000:01:00.0] SCHED_ERROR [UNK06]

The couple more messages follow before the boot hangs:

nouveau E[    DRM] failed to idle channel 0xcccc0001 [DRM]
pci_pm_runtime_suspend(): nouveau_pmops_runtime_suspend 0x0/0xf0 [nouveau] returns -16

With Feodra 22, the behavior changed: if I just let the system boot, it hangs silently. If I wait several seconds and then press <Esc>, the above messages appear, then the system continus booting up to:

Starting Terminate Plymouth Boot Screen...

and then hangs. If I press <Esc> once the screen swithces to a graphical console, I can boot all the way, and run X.

Version-Release number of selected component (if applicable):

kernel-4.2.3-200 (and earlier).

How reproducible:

Always.

Steps to Reproduce:

1. Just boot.
2. Optionally press <Esc> after waiting several seconds.

Actual results:

Boot hangs.

Expected results:

Boot should secceed.

Additional info:

Please ask.
Comment 1 Sergei Shtylyov 2016-06-13 15:11:20 EDT
Starting with the kernel v4.3 (?) it now works.

Note You need to log in before you can comment on or make changes to this bug.