Bug 1275170 - Icon shows incorrectly on Chrome after items manually dragged out of frame and released
Icon shows incorrectly on Chrome after items manually dragged out of frame an...
Status: CLOSED NOTABUG
Product: OpenShift Origin
Classification: Red Hat
Component: Management Console (Show other bugs)
3.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Stef Walter
yapei
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-26 04:15 EDT by yapei
Modified: 2015-10-26 09:11 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-26 09:11:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Chrome dragged out of right side (61.22 KB, image/png)
2015-10-26 04:16 EDT, yapei
no flags Details
Chrome dragged out of upper side (59.60 KB, image/png)
2015-10-26 04:16 EDT, yapei
no flags Details

  None (edit)
Description yapei 2015-10-26 04:15:31 EDT
Description of problem:
in Typology view, when manually dragging some items out of the frame and released, item icon shows incorrectly, this happens on Chrome


Version-Release number of selected component (if applicable):
oc v1.0.6-946-g5954394(devenv-rhel_2560)
kubernetes v1.2.0-alpha.1-1107-g4c8e6f4
Chrome 46.0.2490.71

How reproducible:
Always

Steps to Reproduce:
1.Create application
2.Check resources on overview page in Tile View 
3.Check resources on overview page in Typology View 

Actual results:
step3: Some icons are shown incorrectly,covered by small blue box. see attachment

Expected results:
step3: All items should be displayed with correct icon

Additional info:
on Firefox, Safari, iPhone and iPad, it works well 
on IE, there is a bug waiting for upstream fix 
https://bugzilla.redhat.com/show_bug.cgi?id=1260378
https://github.com/mbostock/d3/pull/2548
Comment 1 yapei 2015-10-26 04:16 EDT
Created attachment 1086408 [details]
Chrome dragged out of right side
Comment 2 yapei 2015-10-26 04:16 EDT
Created attachment 1086409 [details]
Chrome dragged out of upper side
Comment 3 Stef Walter 2015-10-26 08:58:27 EDT
That's a textual selection. You've the text in the screen, and the selection is covering the icons.

Jessica, do you typically try to do user-select: none in openshift webconsole, or allow the user to do textual selections. I don't mind fixing this ... but i imagine i can make all sorts of things turn blue, by dragging my mouse over them.
Comment 4 Jessica Forrester 2015-10-26 09:11:22 EDT
Yep I agree with you Stef, hadn't looked at the screenshots yet.  I'd say this is not a bug since Chrome is just deciding at that point that the user is wanting to highlight that "text".

Note You need to log in before you can comment on or make changes to this bug.