This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 127518 - removal of RTLD_GLOBAL from dlopen flags breaks Zend Performance Suite
removal of RTLD_GLOBAL from dlopen flags breaks Zend Performance Suite
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: php (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
David Lawrence
:
: 130852 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-09 05:33 EDT by Joe Orton
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version: 4.3.10-2.4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-21 17:10:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Joe Orton 2004-07-09 05:33:18 EDT
Description of problem:
The php-4.3.1-dlopen.patch patch breaks the Zend Performance Suite
since this comprises multiple modules each of which references symbols
defined by others.

Since php-4.3.6-3 and later dlopen modules without RTLD_GLOBAL the
symbols are not available.

Version-Release number of selected component (if applicable):
4.3.6-3
Comment 1 Joe Orton 2004-08-25 06:10:35 EDT
*** Bug 130852 has been marked as a duplicate of this bug. ***
Comment 3 Joe Orton 2004-12-21 17:10:12 EST
Reverted in 4.3.10-2.4.

Note You need to log in before you can comment on or make changes to this bug.