Bug 1275186 - ValueError: new size same as old size
ValueError: new size same as old size
Status: CLOSED DUPLICATE of bug 1237382
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:3a2b430ab90353b744d62a5784c...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-26 04:48 EDT by Luya Tshimbalanga
Modified: 2015-10-26 19:57 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-26 19:57:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (957.38 KB, text/plain)
2015-10-26 04:48 EDT, Luya Tshimbalanga
no flags Details
File: anaconda.log (62.43 KB, text/plain)
2015-10-26 04:48 EDT, Luya Tshimbalanga
no flags Details
File: environ (614 bytes, text/plain)
2015-10-26 04:48 EDT, Luya Tshimbalanga
no flags Details
File: journalctl (396.99 KB, text/plain)
2015-10-26 04:48 EDT, Luya Tshimbalanga
no flags Details
File: lsblk_output (3.40 KB, text/plain)
2015-10-26 04:48 EDT, Luya Tshimbalanga
no flags Details
File: nmcli_dev_list (1.63 KB, text/plain)
2015-10-26 04:48 EDT, Luya Tshimbalanga
no flags Details
File: os_info (518 bytes, text/plain)
2015-10-26 04:48 EDT, Luya Tshimbalanga
no flags Details
File: program.log (94.00 KB, text/plain)
2015-10-26 04:48 EDT, Luya Tshimbalanga
no flags Details
File: storage.log (315.94 KB, text/plain)
2015-10-26 04:48 EDT, Luya Tshimbalanga
no flags Details
File: ifcfg.log (6.69 KB, text/plain)
2015-10-26 04:48 EDT, Luya Tshimbalanga
no flags Details

  None (edit)
Description Luya Tshimbalanga 2015-10-26 04:48:04 EDT
Description of problem:
Manually setting partition exceeding its size.

Version-Release number of selected component:
anaconda-core-23.19.10-1.fc23.x86_64

The following was filed automatically by anaconda:
anaconda 23.19.10-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python3.4/site-packages/blivet/deviceaction.py", line 436, in __init__
    raise ValueError("new size same as old size")
  File "/usr/lib/python3.4/site-packages/blivet/blivet.py", line 1160, in resizeDevice
    self.devicetree.registerAction(action_class(device, new_size))
  File "/usr/lib64/python3.4/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 798, in _handle_size_change
    self._storage_playground.resizeDevice(use_dev, use_size)
  File "/usr/lib64/python3.4/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 135, in decorated
    return func(*args, **kwargs)
  File "/usr/lib64/python3.4/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 1206, in _save_right_side
    self._handle_size_change(size, old_size, device)
  File "/usr/lib64/python3.4/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 2690, in on_update_settings_clicked
    self._save_right_side(self._current_selector)
  File "/usr/lib64/python3.4/site-packages/pyanaconda/ui/gui/utils.py", line 269, in _run_once_one_arg
    self._func(*args, **kwargs)
ValueError: new size same as old size

Additional info:
cmdline:        /usr/bin/python3  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=/syslinux/vmlinuz0 root=live:LABEL=LIVE ro rd.live.image quiet rhgb rd.live.check
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         4.2.3-300.fc23.x86_64
other involved packages: python3-blivet-1.12.8-1.fc23.noarch, anaconda-gui-23.19.10-1.fc23.x86_64
product:        Fedora
release:        Fedora release 23 (Twenty Three)
type:           anaconda
version:        23
Comment 1 Luya Tshimbalanga 2015-10-26 04:48:19 EDT
Created attachment 1086415 [details]
File: anaconda-tb
Comment 2 Luya Tshimbalanga 2015-10-26 04:48:21 EDT
Created attachment 1086416 [details]
File: anaconda.log
Comment 3 Luya Tshimbalanga 2015-10-26 04:48:22 EDT
Created attachment 1086417 [details]
File: environ
Comment 4 Luya Tshimbalanga 2015-10-26 04:48:28 EDT
Created attachment 1086418 [details]
File: journalctl
Comment 5 Luya Tshimbalanga 2015-10-26 04:48:29 EDT
Created attachment 1086419 [details]
File: lsblk_output
Comment 6 Luya Tshimbalanga 2015-10-26 04:48:30 EDT
Created attachment 1086420 [details]
File: nmcli_dev_list
Comment 7 Luya Tshimbalanga 2015-10-26 04:48:32 EDT
Created attachment 1086421 [details]
File: os_info
Comment 8 Luya Tshimbalanga 2015-10-26 04:48:34 EDT
Created attachment 1086422 [details]
File: program.log
Comment 9 Luya Tshimbalanga 2015-10-26 04:48:39 EDT
Created attachment 1086423 [details]
File: storage.log
Comment 10 Luya Tshimbalanga 2015-10-26 04:48:40 EDT
Created attachment 1086424 [details]
File: ifcfg.log
Comment 11 Brian Lane 2015-10-26 19:57:45 EDT

*** This bug has been marked as a duplicate of bug 1237382 ***

Note You need to log in before you can comment on or make changes to this bug.