Bug 127519 - Non-versioned obsoletes are not handled correctly
Summary: Non-versioned obsoletes are not handled correctly
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Paul Nasrat
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-07-09 09:48 UTC by Miloslav Trmac
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-24 09:14:00 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Non-versioned obsolete wins over any version (526 bytes, patch)
2004-07-09 09:54 UTC, Miloslav Trmac
no flags Details | Diff

Description Miloslav Trmac 2004-07-09 09:48:43 UTC
In anaconda CVS as of Jul 8 2004, non-versioned obsoletes
are basically ignored because rpm.labelCompare ((0, None, None), (0,
'0', '0')) == -1

The attached patch is a minimal fix, you might want to
avoid the labelCompare completely.

Comment 1 Miloslav Trmac 2004-07-09 09:54:24 UTC
Created attachment 101744 [details]
Non-versioned obsolete wins over any version

Comment 2 Paul Nasrat 2004-07-12 13:14:35 UTC
Commited a fix to HEAD that avoids the labelCompare.

Thanks


Note You need to log in before you can comment on or make changes to this bug.