Bug 127519 - Non-versioned obsoletes are not handled correctly
Non-versioned obsoletes are not handled correctly
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-09 05:48 EDT by Miloslav Trmac
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-24 04:14:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Non-versioned obsolete wins over any version (526 bytes, patch)
2004-07-09 05:54 EDT, Miloslav Trmac
no flags Details | Diff

  None (edit)
Description Miloslav Trmac 2004-07-09 05:48:43 EDT
In anaconda CVS as of Jul 8 2004, non-versioned obsoletes
are basically ignored because rpm.labelCompare ((0, None, None), (0,
'0', '0')) == -1

The attached patch is a minimal fix, you might want to
avoid the labelCompare completely.
Comment 1 Miloslav Trmac 2004-07-09 05:54:24 EDT
Created attachment 101744 [details]
Non-versioned obsolete wins over any version
Comment 2 Paul Nasrat 2004-07-12 09:14:35 EDT
Commited a fix to HEAD that avoids the labelCompare.

Thanks

Note You need to log in before you can comment on or make changes to this bug.