Bug 1275243 - sosreport integration for CloudForms diagnostic tooling
sosreport integration for CloudForms diagnostic tooling
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: sos (Show other bugs)
6.7
Unspecified Unspecified
high Severity medium
: rc
: 6.8
Assigned To: Shane Bradley
BaseOS QE - Apps
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-26 07:03 EDT by Martin Frodl
Modified: 2016-01-18 12:43 EST (History)
15 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 752666
Environment:
Last Closed: 2016-01-18 12:43:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Frodl 2015-10-26 07:03:57 EDT
In RHEL 6.3, the cloudforms plugin was added to sos (bug 752666). This functionality was lost during the rebase to sos 3.2 in RHEL 6.7 (bug 1144525).

Version-Release number of selected component (if applicable):
sos-3.2-28.el6.noarch
Comment 2 Bryn M. Reeves 2015-10-26 07:19:21 EDT
It's not immediately clear what's needed here: the cloudforms plugin was removed and replaced with foremn and katello plugins by one of the sysmanagement developers:

commit a6dc4a5d532a7213a1bf5149087d33b76c42583e
Author: Lukas Zapletal <lzap+git@redhat.com>
Date:   Thu Oct 10 14:09:53 2013 +0200

    Adding plugins foreman and katello
    
    Since CloudForms 1.0 has been renamed to Satellite 6.0, I am deleting this
    plugin and providing two other plugins. Both projects Katello and Foreman
    are upstream projects for Satellite 6.0 Red Hat products. Since both
    projects support deployment on non-redhat systems, they both deliver own
    reporting script that collects information from target system. Both scripts
    have options not to create tarball and to provide output to desired
    directory. This has been tested on RHEL 6.4.
    
    Signed-off-by: Lukas Zapletal <lzap+git@redhat.com>

There is some difference in the data collected: we'll need to understand if any of this is still relevant for RHEL6 and whether it should be added back upstream or as a distro-specific patch.
Comment 3 Martin Frodl 2015-10-26 07:44:12 EDT
From the two plugins you mention, I only see 'foreman' in sos-3.2-28.el6.noarch; there is no 'katello' present:

# grep foreman $(rpm -ql sos) 2> /dev/null
/usr/lib/python2.6/site-packages/sos/plugins/foreman.py:    plugin_name = 'foreman'
/usr/lib/python2.6/site-packages/sos/plugins/foreman.py:    packages = ('foreman-debug')
/usr/lib/python2.6/site-packages/sos/plugins/foreman.py:        cmd = "foreman-debug"
/usr/lib/python2.6/site-packages/sos/plugins/foreman.py:        path = self.get_cmd_output_path(name="foreman-debug")
Binary file /usr/lib/python2.6/site-packages/sos/plugins/foreman.pyc matches
Binary file /usr/lib/python2.6/site-packages/sos/plugins/foreman.pyo matches

# grep katello $(rpm -ql sos) 2> /dev/null
#

I cannot find the katello plugin in upstream either, is it really out there?

According to upstream project documentation, katello should be supported on RHEL 6 as well as 7:

http://www.katello.org/docs/2.3/installation/index.html
Comment 4 Bryn M. Reeves 2015-10-26 07:47:51 EDT
Right: the data it collected was later merged into the foreman-debug script and the separate plugin was removed:

commit 5cc06136d68536b806ce09ce61f800d9a7938790
Author: Lukas Zapletal <lzap+git@redhat.com>
Date:   Tue Feb 3 16:42:11 2015 +0100

    [foreman] Skip collection of generic resources
    
    New option was added to foreman-debug (-g) to skip collecting of generic
    resources (firewall, selinux, cpu, memory). This patch leverages that.
    
    https://github.com/theforeman/foreman/blob/develop/script/foreman-debug
    
    Since katello-debug is now part of foreman-debug (as a plugin), there is no
    need of separate sosreport plugin.
    
    https://github.com/Katello/katello/blob/master/deploy/script/katello-debug.sh
    
    New subpackage called foreman-debug was introduced. It is present in both
    upstream Foreman and Katello installations as well as on both Satellite 6 main
    node and capsule instances. It can be used to detect if foreman-debug script is
    present.
    
    Signed-off-by: Lukas Zapletal <lzap+git@redhat.com>

We'll need to talk to Lukas and the foreman team to understand whether this is appropriate for the pieces still shipped in RHEL6 or not.
Comment 5 Martin Frodl 2015-10-26 09:24:21 EDT
(In reply to Bryn M. Reeves from comment #4)

> We'll need to talk to Lukas and the foreman team to understand whether this
> is appropriate for the pieces still shipped in RHEL6 or not.

Lukáš, can you confirm this conjecture? Is it safe to forget about sosreport's katello plugin on RHEL altogether?
Comment 6 Lukas Zapletal 2015-11-02 06:41:41 EST
Hello, since Katello is now a Foreman plugin, it cannot be installed without Foreman, thus the data collection script was refactored into foreman-data "plugin" as well.

Yes, katello separate sos report is dead now. In the same patch, I have removed

sos/plugins/cloudforms.py | 38 --------------------------------------

because I believe this piece was created for pre-CloudForms product Katello. I think deleting katello-debug sos plugin was correct, but now I see I also accidentaly removed "aeolus-debug" plugin with this. If this is still relevant, we need to add this back. Sorry about that.
Comment 7 David Kutálek 2015-11-25 05:40:50 EST
we have test, acking
Comment 9 Josep 'Pep' Turro Mauri 2016-01-18 12:43:00 EST
(In reply to Lukas Zapletal from comment #6)
> Hello, since Katello is now a Foreman plugin, it cannot be installed without
> Foreman, thus the data collection script was refactored into foreman-data
> "plugin" as well.
> 
> Yes, katello separate sos report is dead now. In the same patch, I have
> removed
> 
> sos/plugins/cloudforms.py | 38 --------------------------------------
> 
> because I believe this piece was created for pre-CloudForms product Katello.
> I think deleting katello-debug sos plugin was correct,

Right, the current foreman plugin should take care of collecting the relevant data for the current sysmgmt product. [potential] bugs on that plugin should go to their own bugzilla.

> but now I see I also
> accidentaly removed "aeolus-debug" plugin with this. If this is still
> relevant, we need to add this back. Sorry about that.

It's not relevant anymore. It's kind of confusing, so to clarify the referenced cloudforms plugin was created when the "cloudforms" was in its version 1.x, and Aeolus what the upstream project for it. Several things changed since then, and that product is quite different now:

  - the aeolus project was discontinued
  - manageiq replaced the virt/cloud management functionality as upstream for cloudforms. There's a proposed manageiq sos plugin in bug 1206252
  - foreman (and satellite 6) replaced the system management functionality and are covered by the foreman plugin 

So these changes in the sos plugins (removal of cloudforms.py including invocation to aeolus-debug) match these product changes and are expected.

Note You need to log in before you can comment on or make changes to this bug.