Bug 1275265 - Fails to build when all %bcond_with(out) are disabled
Fails to build when all %bcond_with(out) are disabled
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: llvm (Show other bugs)
24
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-26 08:15 EDT by Milan Bouchet-Valat
Modified: 2016-06-05 08:39 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-05 08:39:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milan Bouchet-Valat 2015-10-26 08:15:16 EDT
For debugging purposes I tried building llvm disabling all %bcond_with an %bcond_without options. I noticed the package doesn't build in that case. The patch below fixed it.

@@ -335,7 +336,9 @@
 sed -i 's|/lib /usr/lib $lt_ld_extra|%{_libdir} $lt_ld_extra|' configure
 sed -i 's|(PROJ_prefix)/lib|(PROJ_prefix)/%{_lib}/%{name}|g' Makefile.config.in
 sed -i 's|/lib\>|/%{_lib}/%{name}|g' tools/llvm-config/llvm-config.cpp
+%if %{with crt}
 sed -ri "/ifeq.*CompilerTargetArch/s#i386#i686#g" projects/compiler-rt/make/platform/clang_linux.mk
+%endif
 
 %build
 %ifarch s390
@@ -611,7 +612,6 @@
 %if %{with lldb}
 %exclude %{_mandir}/man1/lldb.1.*
 %endif
-%doc %{_mandir}/man1/*.1.*
 
 %files devel
 %doc %{llvmdocdir %{name}-devel}/
Comment 1 Jan Kurik 2016-02-24 10:42:54 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 2 Jan Včelák 2016-06-05 08:39:57 EDT
Package has been reworked since.

Note You need to log in before you can comment on or make changes to this bug.