Bug 127529 - [PATCH] support for the new ioctl based AFS interface in pam_krb5 minikafs
[PATCH] support for the new ioctl based AFS interface in pam_krb5 minikafs
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pam_krb5 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
Brian Brock
: EasyFix, FutureFeature, Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-09 10:50 EDT by Alexander Boström
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version: 2.1.2-1
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-31 10:51:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to add procfs ioctl based AFS interface support. (3.00 KB, patch)
2004-07-09 10:52 EDT, Alexander Boström
no flags Details | Diff

  None (edit)
Description Alexander Boström 2004-07-09 10:50:39 EDT
OpenAFS and Arla has a new ioctl based interface that replaces the old
syscall. Since the syscall is gone, minikafs won't work with new
kernels and AFS clients. Attached is a patch that adds support for the
new interface in minikafs.
Comment 1 Alexander Boström 2004-07-09 10:52:33 EDT
Created attachment 101750 [details]
Patch to add procfs ioctl based AFS interface support.
Comment 2 Alexander Boström 2004-08-25 18:05:15 EDT
Ok, so we don't love ioctls, but it's what we've got at the moment. 

Also, until either the kernel implements the AFS syscall, minikafs
starts using the AFS ioctl or something else is done, minikafs won't
work at all.
Comment 3 Nalin Dahyabhai 2004-08-31 10:51:34 EDT
I really haven't got a problem with ioctls.  The patch doesn't need to
strdup() the path which was opened, though, the global could as easily
be a const pointer to the literal.  Otherwise, looks good.  Merging
into 2.1.2.  Thanks!

Note You need to log in before you can comment on or make changes to this bug.