Bug 127530 - rescue mode fails to symlink /etc to /mnt/runtime/etc
rescue mode fails to symlink /etc to /mnt/runtime/etc
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
: 128061 128692 129347 130612 130659 131020 131157 131902 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-09 10:59 EDT by Alexandre Oliva
Modified: 2007-11-30 17:10 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-10 14:06:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexandre Oliva 2004-07-09 10:59:19 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
Traceback issued by anaconda when booted in rescue mode:
  File "/usr/bin/anaconda", line 592, in ?
    rescue.runRescue(rootPath, not escue_nomount, id)
  File "/usr/lib/anaconda/rescue.py", line 167, in runRescue
    os.symlink('/mnt/runtime/etc/' + file, '/etc/' + file)
OSError: [Errno 17] File exists.


Version-Release number of selected component (if applicable):
anaconda-10.0.1-2.src.rpm

How reproducible:
Always

Steps to Reproduce:
1.Boot the rescue CD in the default mode.

Actual Results:  The exception above.

Expected Results:  Enter rescue mode.

Additional info:

The fact that I have LVM on this system may have something to do with
the presence of /etc.  Unfortunately I can't test this theory because
all of my boxes have LVM.
Comment 1 Jeremy Katz 2004-07-09 11:09:50 EDT
Actually caused by a last minute change to workaround brokenness in
libselinux :/

Fixed in CVS
Comment 2 Jeremy Katz 2004-07-16 17:54:10 EDT
*** Bug 128061 has been marked as a duplicate of this bug. ***
Comment 3 Jeremy Katz 2004-07-28 11:15:39 EDT
*** Bug 128692 has been marked as a duplicate of this bug. ***
Comment 4 Jeremy Katz 2004-08-09 17:34:25 EDT
*** Bug 129347 has been marked as a duplicate of this bug. ***
Comment 5 Leonard den Ottolander 2004-08-09 19:55:08 EDT
Note that bug 129347 is about running rescue mode over NFS, using (non
anonymous) FTP doesn't give me the same error.
Comment 6 Leonard den Ottolander 2004-08-10 11:53:12 EDT
boot.iso and base from 2004-08-09 fix the NFS issue for me.

Not sure what "Boot the rescue CD in the default mode" means (what is
the rescue CD?) but I guess this bug can be closed RAWHIDE.
Comment 7 Jeremy Katz 2004-08-13 10:24:35 EDT
*** Bug 129849 has been marked as a duplicate of this bug. ***
Comment 8 Jeremy Katz 2004-08-23 10:57:54 EDT
*** Bug 130612 has been marked as a duplicate of this bug. ***
Comment 9 Jeremy Katz 2004-08-23 10:58:04 EDT
*** Bug 130659 has been marked as a duplicate of this bug. ***
Comment 10 Jeremy Katz 2004-08-27 12:58:51 EDT
*** Bug 131020 has been marked as a duplicate of this bug. ***
Comment 11 Jeremy Katz 2004-08-30 11:28:40 EDT
*** Bug 131157 has been marked as a duplicate of this bug. ***
Comment 12 Jeremy Katz 2004-09-07 00:36:38 EDT
*** Bug 131902 has been marked as a duplicate of this bug. ***
Comment 13 Alexandre Oliva 2004-10-02 16:19:17 EDT
Confirmed fixed in re1001.0, thanks.

Note You need to log in before you can comment on or make changes to this bug.