Bug 1275375 - ERROR Failed to find host on any provider by host name appears frequently in engine.log:
ERROR Failed to find host on any provider by host name appears frequently in ...
Status: CLOSED DUPLICATE of bug 1260499
Product: ovirt-engine
Classification: oVirt
Component: BLL.Infra (Show other bugs)
3.6.0.2
Unspecified Unspecified
unspecified Severity medium (vote)
: ---
: ---
Assigned To: Oved Ourfali
Pavel Stehlik
infra
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-26 13:22 EDT by Natalie Gavrielov
Modified: 2016-02-10 14:23 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-26 13:47:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
ngavrilo: planning_ack?
ngavrilo: devel_ack?
ngavrilo: testing_ack?


Attachments (Terms of Use)
engine.log (117.28 KB, application/x-gzip)
2015-10-26 13:22 EDT, Natalie Gavrielov
no flags Details

  None (edit)
Description Natalie Gavrielov 2015-10-26 13:22:00 EDT
Created attachment 1086561 [details]
engine.log

Description of problem:

Since switching to the new build, the engine.log is filling up with the following error:
Failed to find host on any provider by host name

Version-Release number of selected component (if applicable):
rhevm-3.6.0.2-0.1.el6.noarch

How reproducible:
100%

Steps to Reproduce:
Nothing AFAIK, just upgrade to 3.6.0.2.

Actual results:
Many errors appear in the engine.log:
2015-10-26 16:33:23,370 ERROR [org.ovirt.engine.core.bll.host.provider.foreman.SystemProviderFinder] (ajp-/127.0.0.1:8702-1) [] Failed to find host on any provider by host name 'ngavrilo-rhevm.scl.lab.tlv.redhat.com'

Expected results:

1. Get less of these errors (in one log I got ~41).
2. Maybe this should appear as a warning.
3. Have some sort of reference on how to solve it: "go to..", "check some settings.." etc.

Additional info:
Happens on other environments too, for example, Elad's:
2015-10-26 16:56:52,196 ERROR [org.ovirt.engine.core.bll.host.provider.foreman.SystemProviderFinder] (ajp-/127.0.0.1:8702-3) [] Failed to find host on any provider by host name 'elad-he.qa.lab.tlv.redhat.com'
Comment 1 Oved Ourfali 2015-10-26 13:39:23 EDT
Moti, that's a duplicate, right?
Comment 2 Moti Asayag 2015-10-26 13:47:05 EDT
(In reply to Oved Ourfali from comment #1)
> Moti, that's a duplicate, right?

Yes, this is a duplicate of Bug 1260499 which was fixed and merged to 3.6.1

*** This bug has been marked as a duplicate of bug 1260499 ***

Note You need to log in before you can comment on or make changes to this bug.