Bug 1275537 - [platformmanagement_public_514]`oc import-image` will hang there when ImageStream is pointing to non-existing docker image
[platformmanagement_public_514]`oc import-image` will hang there when ImageSt...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Image Registry (Show other bugs)
3.x
Unspecified Unspecified
medium Severity high
: ---
: ---
Assigned To: Maciej Szulik
Wei Sun
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-27 04:08 EDT by Wei Sun
Modified: 2015-11-23 16:14 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-23 16:14:54 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wei Sun 2015-10-27 04:08:07 EDT
Description of problem:
Create an ImageStream(ImageStream is pointing to non-existing docker image),and import the image from the ImageStream,but `oc import-image` will hang there.

Version-Release number of selected component (if applicable):
devenv-rhel7_2566
# oc version
oc v1.0.6-958-gaf948e1
kubernetes v1.2.0-alpha.1-1107-g4c8e6f4

How reproducible:
Always

Steps to Reproduce:
1.Create an ImageStream(ImageStream is pointing to non-existing docker image)
2.Import image from the ImageStream
3.

Actual results:
1.$ oc get is python -o json
{
    "kind": "ImageStream",
    "apiVersion": "v1",
    "metadata": {
        "name": "python",
        "namespace": "wsuntest",
        "selfLink": "/oapi/v1/namespaces/wsuntest/imagestreams/python",
        "uid": "bf244a10-7c77-11e5-a705-0e40f0cd8f0d",
        "resourceVersion": "1979",
        "creationTimestamp": "2015-10-27T06:55:45Z"
    },
    "spec": {
        "dockerImageRepository": "wsun/non-existen-image",
        "tags": [
            {
                "name": "test",
                "annotations": {
                    "description": "wsun tests"
                },
                "from": {
                    "kind": "DockerImage",
                    "name": "wsun/non-existen-image"
                }
            }
        ]
    },
    "status": {
        "dockerImageRepository": "172.30.49.170:5000/wsuntest/python"
    }
}

2.$ oc import-image python --loglevel=8
I1027 14:58:25.606909   19913 debugging.go:99] GET https://ec2-52-91-56-153.compute-1.amazonaws.com:8443/api
I1027 14:58:25.606968   19913 debugging.go:106] Request Headers:
I1027 14:58:25.606979   19913 debugging.go:109]     Authorization: Bearer jBcuF_ibKDVNLHQ4B0ydAOi-Ge0u7snH0fUnHGEbMdM
I1027 14:58:25.606989   19913 debugging.go:109]     User-Agent: oc/v1.2.0 (linux/amd64) kubernetes/4c8e6f4
I1027 14:58:27.772828   19913 debugging.go:124] Response Status: 200 OK in 2165 milliseconds
I1027 14:58:27.772935   19913 debugging.go:127] Response Headers:
I1027 14:58:27.772978   19913 debugging.go:130]     Cache-Control: no-store
I1027 14:58:27.773021   19913 debugging.go:130]     Content-Type: application/json
I1027 14:58:27.773061   19913 debugging.go:130]     Date: Tue, 27 Oct 2015 06:58:27 GMT
I1027 14:58:27.773098   19913 debugging.go:130]     Content-Length: 32
I1027 14:58:27.773195   19913 request.go:777] Response Body: {
  "versions": [
    "v1"
  ]
}
I1027 14:58:27.803452   19913 debugging.go:99] GET https://ec2-52-91-56-153.compute-1.amazonaws.com:8443/oapi
I1027 14:58:27.803484   19913 debugging.go:106] Request Headers:
I1027 14:58:27.803494   19913 debugging.go:109]     User-Agent: oc/v3.0.2.903 (linux/amd64) openshift/49953d6
I1027 14:58:27.803504   19913 debugging.go:109]     Authorization: Bearer jBcuF_ibKDVNLHQ4B0ydAOi-Ge0u7snH0fUnHGEbMdM
I1027 14:58:28.205049   19913 debugging.go:124] Response Status: 200 OK in 401 milliseconds
I1027 14:58:28.205117   19913 debugging.go:127] Response Headers:
I1027 14:58:28.205140   19913 debugging.go:130]     Content-Length: 32
I1027 14:58:28.205162   19913 debugging.go:130]     Cache-Control: no-store
I1027 14:58:28.205182   19913 debugging.go:130]     Content-Type: application/json
I1027 14:58:28.205203   19913 debugging.go:130]     Date: Tue, 27 Oct 2015 06:58:28 GMT
I1027 14:58:28.205305   19913 request.go:777] Response Body: {
  "versions": [
    "v1"
  ]
}
I1027 14:58:28.206051   19913 debugging.go:99] GET https://ec2-52-91-56-153.compute-1.amazonaws.com:8443/oapi/v1/namespaces/wsuntest/imagestreams/python
I1027 14:58:28.206083   19913 debugging.go:106] Request Headers:
I1027 14:58:28.206101   19913 debugging.go:109]     User-Agent: oc/v3.0.2.903 (linux/amd64) openshift/49953d6
I1027 14:58:28.206121   19913 debugging.go:109]     Authorization: Bearer jBcuF_ibKDVNLHQ4B0ydAOi-Ge0u7snH0fUnHGEbMdM
I1027 14:58:28.608772   19913 debugging.go:124] Response Status: 200 OK in 402 milliseconds
I1027 14:58:28.608834   19913 debugging.go:127] Response Headers:
I1027 14:58:28.608857   19913 debugging.go:130]     Cache-Control: no-store
I1027 14:58:28.608878   19913 debugging.go:130]     Content-Type: application/json
I1027 14:58:28.608899   19913 debugging.go:130]     Date: Tue, 27 Oct 2015 06:58:28 GMT
I1027 14:58:28.608919   19913 debugging.go:130]     Content-Length: 528
I1027 14:58:28.609024   19913 request.go:777] Response Body: {"kind":"ImageStream","apiVersion":"v1","metadata":{"name":"python","namespace":"wsuntest","selfLink":"/oapi/v1/namespaces/wsuntest/imagestreams/python","uid":"bf244a10-7c77-11e5-a705-0e40f0cd8f0d","resourceVersion":"1906","creationTimestamp":"2015-10-27T06:55:45Z"},"spec":{"dockerImageRepository":"wsun/non-existen-image","tags":[{"name":"test","annotations":{"description":"wsun tests"},"from":{"kind":"DockerImage","name":"wsun/non-existen-image"}}]},"status":{"dockerImageRepository":"172.30.49.170:5000/wsuntest/python"}}
I1027 14:58:28.614180   19913 request.go:524] Request Body: {"kind":"ImageStream","apiVersion":"v1","metadata":{"name":"python","namespace":"wsuntest","selfLink":"/oapi/v1/namespaces/wsuntest/imagestreams/python","uid":"bf244a10-7c77-11e5-a705-0e40f0cd8f0d","resourceVersion":"1906","creationTimestamp":"2015-10-27T06:55:45Z"},"spec":{"dockerImageRepository":"wsun/non-existen-image","tags":[{"name":"test","annotations":{"description":"wsun tests"},"from":{"kind":"DockerImage","name":"wsun/non-existen-image"}}]},"status":{"dockerImageRepository":"172.30.49.170:5000/wsuntest/python"}}
I1027 14:58:28.614334   19913 debugging.go:99] PUT https://ec2-52-91-56-153.compute-1.amazonaws.com:8443/oapi/v1/namespaces/wsuntest/imagestreams/python
I1027 14:58:28.614376   19913 debugging.go:106] Request Headers:
I1027 14:58:28.614396   19913 debugging.go:109]     User-Agent: oc/v3.0.2.903 (linux/amd64) openshift/49953d6
I1027 14:58:28.614416   19913 debugging.go:109]     Authorization: Bearer jBcuF_ibKDVNLHQ4B0ydAOi-Ge0u7snH0fUnHGEbMdM
I1027 14:58:29.040795   19913 debugging.go:124] Response Status: 200 OK in 426 milliseconds
I1027 14:58:29.040830   19913 debugging.go:127] Response Headers:
I1027 14:58:29.040841   19913 debugging.go:130]     Cache-Control: no-store
I1027 14:58:29.040850   19913 debugging.go:130]     Content-Type: application/json
I1027 14:58:29.040859   19913 debugging.go:130]     Date: Tue, 27 Oct 2015 06:58:28 GMT
I1027 14:58:29.040869   19913 debugging.go:130]     Content-Length: 528
I1027 14:58:29.040907   19913 request.go:777] Response Body: {"kind":"ImageStream","apiVersion":"v1","metadata":{"name":"python","namespace":"wsuntest","selfLink":"/oapi/v1/namespaces/wsuntest/imagestreams/python","uid":"bf244a10-7c77-11e5-a705-0e40f0cd8f0d","resourceVersion":"1923","creationTimestamp":"2015-10-27T06:55:45Z"},"spec":{"dockerImageRepository":"wsun/non-existen-image","tags":[{"name":"test","annotations":{"description":"wsun tests"},"from":{"kind":"DockerImage","name":"wsun/non-existen-image"}}]},"status":{"dockerImageRepository":"172.30.49.170:5000/wsuntest/python"}}
Waiting for the import to complete, CTRL+C to stop waiting.
I1027 14:58:29.041432   19913 debugging.go:99] GET https://ec2-52-91-56-153.compute-1.amazonaws.com:8443/oapi/v1/watch/namespaces/wsuntest/imagestreams?fieldSelector=name%3Dpython&resourceVersion=1923
I1027 14:58:29.041445   19913 debugging.go:106] Request Headers:
I1027 14:58:29.041454   19913 debugging.go:109]     User-Agent: oc/v3.0.2.903 (linux/amd64) openshift/49953d6
I1027 14:58:29.041463   19913 debugging.go:109]     Authorization: Bearer jBcuF_ibKDVNLHQ4B0ydAOi-Ge0u7snH0fUnHGEbMdM
I1027 14:58:29.438907   19913 debugging.go:124] Response Status: 200 OK in 397 milliseconds
I1027 14:58:29.438974   19913 debugging.go:127] Response Headers:
I1027 14:58:29.439063   19913 debugging.go:130]     Cache-Control: no-store
I1027 14:58:29.439092   19913 debugging.go:130]     Date: Tue, 27 Oct 2015 06:58:29 GMT
I1027 14:58:29.439113   19913 debugging.go:130]     Content-Type: text/plain; charset=utf-8


Expected results:
Could not import the image successfully,but should have friendly prompt

Additional info:
Comment 1 Maciej Szulik 2015-10-30 16:12:07 EDT
Should be fixed in https://github.com/openshift/origin/pull/5546
Comment 2 Clayton Coleman 2015-11-03 10:38:41 EST
This is high severity because it is a regression from 3.0.2
Comment 3 Wei Sun 2015-11-04 02:36:37 EST
Checked this bug by git clone the latest code,the bug has been fixed.

# openshift version
openshift v1.0.7-255-g550b949
kubernetes v1.2.0-alpha.1-1107-g4c8e6f4
etcd 2.1.2


#  oc import-image python
Waiting for the import to complete, CTRL+C to stop waiting.
error: unable to import image: [the repository "wsun/non-existen-image" was not found, tag "latest" has not been set on repository "wsun/non-existen-image"]


I will check it again after the devenv-rhel7_2638+ is ready.
Comment 4 Wei Sun 2015-11-04 20:47:56 EST
The bug has been fixed in devenv-rhel7_2638,so verified this bug.

Note You need to log in before you can comment on or make changes to this bug.