Bug 1275624 - updates for 3.1.2 Package Manifest Guide
updates for 3.1.2 Package Manifest Guide
Status: VERIFIED
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: Documentation (Show other bugs)
3.1
Unspecified Unspecified
unspecified Severity high
: ---
: RHGS 3.1.2
Assigned To: Divya
storage-qa-internal@redhat.com
: Documentation, ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-27 07:29 EDT by Anjana Suparna Sriram
Modified: 2016-11-23 18:15 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anjana Suparna Sriram 2015-10-27 07:29:42 EDT
Document URL: https://access.redhat.com/documentation/en-US/Red_Hat_Storage/3.1/html/Package_Manifest/index.html


Additional information: New packages information to be added as part of 3.1.2 release
Comment 2 Divya 2015-11-04 03:23:48 EST
Sreenath,

Could you please let me know the packages' information that are added in 3.1.2 release? Also, do let me know the packages that are deleted in 3.1.2 relase?

For reference, 3.1.1 Package Manifest guide is available at: https://access.redhat.com/documentation/en-US/Red_Hat_Storage/3.1/html/Package_Manifest/index.html


Thanks!
Comment 4 Sreenath G 2015-12-22 07:52:44 EST
Packages added in RHGS-3.1u2-RHEL-7

heketi ASL 2.0
heketi-devel ASL 2.0
heketi-unit-test-devel ASL 2.0

Packages added in RHGS-3.1u2-RHEL-6

heketi ASL 2.0
heketi-devel ASL 2.0
heketi-unit-test-devel ASL 2.0

Also there are some packages in 3.1 update 2 , which got moved from RHGS-Server variant to RH-Glustert-Samba variant. This can be provided soon.
Comment 5 Sreenath G 2015-12-23 06:54:54 EST
Packages added 

RHGS-3.1u2-RHEL-7
-----------------
heketi ASL 2.0
heketi-devel ASL 2.0
heketi-unit-test-devel ASL 2.0

RHGS-3.1u2-RHEL-6
-------------------
heketi ASL 2.0
heketi-devel ASL 2.0
heketi-unit-test-devel ASL 2.0



Packages changed variants from RH-Gluster-Server to RH-Gluster-Samba after RHGS-3.1 update 1
----------------------------------------------------------------------

RHGS-3.1.2-RHEL-7
-----------------
libtdb-1.3.6-2.el7rhgs
libtevent-0.9.25-1.el7rhgs
libtalloc-2.1.2-1.el7rhgs


RHGS-3.1.2-RHEL-6
-----------------
libtdb-1.3.6-2.el6rhs
libtalloc-2.1.2-1.el6rhs
libtevent-0.9.25-1.el6rhs

Packages that need to be deprecated/removed (proposed by Development)
---------------------------------------------------

RHGS-3.1.2-RHEL-7
-----------------
ctdb2.5-2.5.5-7.el7rhgs


RHGS-3.1.2-RHEL-6
-----------------
ctdb2.5-2.5.5-7.el6rhs
Comment 6 Divya 2015-12-28 02:48:39 EST
Sreenath,

My comments in line.

(In reply to Sreenath G from comment #5)
> Packages added 
> 
> RHGS-3.1u2-RHEL-7
> -----------------
> heketi ASL 2.0
> heketi-devel ASL 2.0
> heketi-unit-test-devel ASL 2.0
> 
> RHGS-3.1u2-RHEL-6
> -------------------
> heketi ASL 2.0
> heketi-devel ASL 2.0
> heketi-unit-test-devel ASL 2.0

I have added the heketi package information here: http://jenkinscat.gsslab.pnq.redhat.com:8080/job/doc-Red_Hat_Gluster_Storage-3.1-Package_Manifest-en-US%20%28html-single%29/lastStableBuild/artifact/tmp/en-US/html-single/index.html

Could you let me know the Core Package column information for these packages?

> 
> 
> 
> Packages changed variants from RH-Gluster-Server to RH-Gluster-Samba after
> RHGS-3.1 update 1
> ----------------------------------------------------------------------
> 
> RHGS-3.1.2-RHEL-7
> -----------------
> libtdb-1.3.6-2.el7rhgs
> libtevent-0.9.25-1.el7rhgs
> libtalloc-2.1.2-1.el7rhgs
> 
> 
> RHGS-3.1.2-RHEL-6
> -----------------
> libtdb-1.3.6-2.el6rhs
> libtalloc-2.1.2-1.el6rhs
> libtevent-0.9.25-1.el6rhs

I have moved these packages to RH-Gluster-Samba section.

Link to the doc: http://jenkinscat.gsslab.pnq.redhat.com:8080/job/doc-Red_Hat_Gluster_Storage-3.1-Package_Manifest-en-US%20%28html-single%29/lastStableBuild/artifact/tmp/en-US/html-single/index.html

> 
> Packages that need to be deprecated/removed (proposed by Development)
> ---------------------------------------------------
> 
> RHGS-3.1.2-RHEL-7
> -----------------
> ctdb2.5-2.5.5-7.el7rhgs
> 
> 
> RHGS-3.1.2-RHEL-6
> -----------------
> ctdb2.5-2.5.5-7.el6rhs

Please let me know if I can go ahead and add these packages under "Deprecated Packages in Red Hat Gluster Storage 3.1 Update 2 Release" section.

Thanks!
Comment 7 Sreenath G 2016-01-11 06:24:53 EST
(In reply to Divya from comment #6)
> Sreenath,
> 
> My comments in line.
> 
> (In reply to Sreenath G from comment #5)
> > Packages added 
> > 
RHGS-3.1u2-RHEL-7
-----------------

heketi                 ASL 2.0    N
heketi-devel           ASL 2.0    N
heketi-unit-test-devel ASL 2.0    N

> > 
RHGS-3.1u2-RHEL-6
-------------------
heketi                 ASL 2.0    N
heketi-devel           ASL 2.0    N
heketi-unit-test-devel ASL 2.0    N

> 
> I have added the heketi package information here:
> http://jenkinscat.gsslab.pnq.redhat.com:8080/job/doc-Red_Hat_Gluster_Storage-
> 3.1-Package_Manifest-en-US%20%28html-single%29/lastStableBuild/artifact/tmp/
> en-US/html-single/index.html
> 
> Could you let me know the Core Package column information for these packages?
> 
> > 
> > 
> > 
> > Packages changed variants from RH-Gluster-Server to RH-Gluster-Samba after
> > RHGS-3.1 update 1
> > ----------------------------------------------------------------------
> > 

I am adding ctdb to this list as it has been added as a sub-pkg of samba package

RHGS-3.1.2-RHEL-7
-----------------
libtdb-1.3.6-2.el7rhgs     LGPLv3+    N
libtevent-0.9.25-1.el7rhgs LGPLv3+    N
libtalloc-2.1.2-1.el7rhgs  LGPLv3+    N
ctdb              GPLv3+ and LGPLv3+  N


> > 
> > 
RHGS-3.1.2-RHEL-6
-----------------
libtdb-1.3.6-2.el6rhs     LGPLv3+    N
libtalloc-2.1.2-1.el6rhs  LGPLv3+    N
libtevent-0.9.25-1.el6rhs LGPLv3+    N
ctdb           GPLv3+ and LGPLv3+    N

 
> I have moved these packages to RH-Gluster-Samba section.
> 
> Link to the doc:
> http://jenkinscat.gsslab.pnq.redhat.com:8080/job/doc-Red_Hat_Gluster_Storage-
> 3.1-Package_Manifest-en-US%20%28html-single%29/lastStableBuild/artifact/tmp/
> en-US/html-single/index.html
> 
> > 
> > Packages that need to be deprecated/removed (proposed by Development)
> > ---------------------------------------------------
> > 

RHGS-3.1.2-RHEL-7
-----------------
ctdb2.5-2.5.5-7.el7rhgs
 
 
RHGS-3.1.2-RHEL-6
-----------------
ctdb2.5-2.5.5-7.el6rhs

 
> Please let me know if I can go ahead and add these packages under
> "Deprecated Packages in Red Hat Gluster Storage 3.1 Update 2 Release"
> section.

Yes. Go ahead.

> 
> Thanks!
Comment 8 Divya 2016-01-12 05:26:39 EST
(In reply to Sreenath G from comment #7)
> (In reply to Divya from comment #6)
> > Sreenath,
> > 
> > My comments in line.
> > 
> > (In reply to Sreenath G from comment #5)
> > > Packages added 
> > > 
> RHGS-3.1u2-RHEL-7
> -----------------
> 
> heketi                 ASL 2.0    N
> heketi-devel           ASL 2.0    N
> heketi-unit-test-devel ASL 2.0    N
> 
> > > 
> RHGS-3.1u2-RHEL-6
> -------------------
> heketi                 ASL 2.0    N
> heketi-devel           ASL 2.0    N
> heketi-unit-test-devel ASL 2.0    N
> 
> > 
> > I have added the heketi package information here:
> > http://jenkinscat.gsslab.pnq.redhat.com:8080/job/doc-Red_Hat_Gluster_Storage-
> > 3.1-Package_Manifest-en-US%20%28html-single%29/lastStableBuild/artifact/tmp/
> > en-US/html-single/index.html
> > 
> > Could you let me know the Core Package column information for these packages?
> > 
> > > 
> > > 
> > > 
> > > Packages changed variants from RH-Gluster-Server to RH-Gluster-Samba after
> > > RHGS-3.1 update 1
> > > ----------------------------------------------------------------------
> > > 
> 
> I am adding ctdb to this list as it has been added as a sub-pkg of samba
> package
> 
> RHGS-3.1.2-RHEL-7
> -----------------
> libtdb-1.3.6-2.el7rhgs     LGPLv3+    N
> libtevent-0.9.25-1.el7rhgs LGPLv3+    N
> libtalloc-2.1.2-1.el7rhgs  LGPLv3+    N
> ctdb              GPLv3+ and LGPLv3+  N
> 
> 
> > > 
> > > 
> RHGS-3.1.2-RHEL-6
> -----------------
> libtdb-1.3.6-2.el6rhs     LGPLv3+    N
> libtalloc-2.1.2-1.el6rhs  LGPLv3+    N
> libtevent-0.9.25-1.el6rhs LGPLv3+    N
> ctdb           GPLv3+ and LGPLv3+    N
> 
>  
> > I have moved these packages to RH-Gluster-Samba section.
> > 
> > Link to the doc:
> > http://jenkinscat.gsslab.pnq.redhat.com:8080/job/doc-Red_Hat_Gluster_Storage-
> > 3.1-Package_Manifest-en-US%20%28html-single%29/lastStableBuild/artifact/tmp/
> > en-US/html-single/index.html
> > 
> > > 
> > > Packages that need to be deprecated/removed (proposed by Development)
> > > ---------------------------------------------------
> > > 
> 
> RHGS-3.1.2-RHEL-7
> -----------------
> ctdb2.5-2.5.5-7.el7rhgs
>  
>  
> RHGS-3.1.2-RHEL-6
> -----------------
> ctdb2.5-2.5.5-7.el6rhs
> 
>  
> > Please let me know if I can go ahead and add these packages under
> > "Deprecated Packages in Red Hat Gluster Storage 3.1 Update 2 Release"
> > section.
> 
> Yes. Go ahead.
> 
> > 
> > Thanks!

I have made all the changes suggested in Comment 7. Could you review and sign-off?

Link to the latest doc: http://jenkinscat.gsslab.pnq.redhat.com:8080/job/doc-Red_Hat_Gluster_Storage-3.1-Package_Manifest-en-US%20%28html-single%29/lastStableBuild/artifact/tmp/en-US/html-single/index.html
Comment 9 Sreenath G 2016-01-12 05:38:49 EST
(In reply to Divya from comment #8)
> (In reply to Sreenath G from comment #7)
> > (In reply to Divya from comment #6)
> > > Sreenath,
> > > 
> > > My comments in line.
> > > 
> > > (In reply to Sreenath G from comment #5)
> > > > Packages added 
> > > > 
> > RHGS-3.1u2-RHEL-7
> > -----------------
> > 
> > heketi                 ASL 2.0    N
> > heketi-devel           ASL 2.0    N
> > heketi-unit-test-devel ASL 2.0    N
> > 
> > > > 
> > RHGS-3.1u2-RHEL-6
> > -------------------
> > heketi                 ASL 2.0    N
> > heketi-devel           ASL 2.0    N
> > heketi-unit-test-devel ASL 2.0    N
> > 
> > > 
> > > I have added the heketi package information here:
> > > http://jenkinscat.gsslab.pnq.redhat.com:8080/job/doc-Red_Hat_Gluster_Storage-
> > > 3.1-Package_Manifest-en-US%20%28html-single%29/lastStableBuild/artifact/tmp/
> > > en-US/html-single/index.html
> > > 
> > > Could you let me know the Core Package column information for these packages?
> > > 
> > > > 
> > > > 
> > > > 
> > > > Packages changed variants from RH-Gluster-Server to RH-Gluster-Samba after
> > > > RHGS-3.1 update 1
> > > > ----------------------------------------------------------------------
> > > > 
> > 
> > I am adding ctdb to this list as it has been added as a sub-pkg of samba
> > package
> > 
> > RHGS-3.1.2-RHEL-7
> > -----------------
> > libtdb-1.3.6-2.el7rhgs     LGPLv3+    N
> > libtevent-0.9.25-1.el7rhgs LGPLv3+    N
> > libtalloc-2.1.2-1.el7rhgs  LGPLv3+    N
> > ctdb              GPLv3+ and LGPLv3+  N
> > 
> > 
> > > > 
> > > > 
> > RHGS-3.1.2-RHEL-6
> > -----------------
> > libtdb-1.3.6-2.el6rhs     LGPLv3+    N
> > libtalloc-2.1.2-1.el6rhs  LGPLv3+    N
> > libtevent-0.9.25-1.el6rhs LGPLv3+    N
> > ctdb           GPLv3+ and LGPLv3+    N
> > 
> >  
> > > I have moved these packages to RH-Gluster-Samba section.
> > > 
> > > Link to the doc:
> > > http://jenkinscat.gsslab.pnq.redhat.com:8080/job/doc-Red_Hat_Gluster_Storage-
> > > 3.1-Package_Manifest-en-US%20%28html-single%29/lastStableBuild/artifact/tmp/
> > > en-US/html-single/index.html
> > > 
> > > > 
> > > > Packages that need to be deprecated/removed (proposed by Development)
> > > > ---------------------------------------------------
> > > > 
> > 
> > RHGS-3.1.2-RHEL-7
> > -----------------
> > ctdb2.5-2.5.5-7.el7rhgs
> >  
> >  
> > RHGS-3.1.2-RHEL-6
> > -----------------
> > ctdb2.5-2.5.5-7.el6rhs



> > 
> >  
> > > Please let me know if I can go ahead and add these packages under
> > > "Deprecated Packages in Red Hat Gluster Storage 3.1 Update 2 Release"
> > > section.
> > 
> > Yes. Go ahead.
> > 
> > > 
> > > Thanks!
> 
> I have made all the changes suggested in Comment 7. Could you review and
> sign-off?
> 
> Link to the latest doc:
> http://jenkinscat.gsslab.pnq.redhat.com:8080/job/doc-Red_Hat_Gluster_Storage-
> 3.1-Package_Manifest-en-US%20%28html-single%29/lastStableBuild/artifact/tmp/
> en-US/html-single/index.html

Please remove ctdb2.5-debuginfo (which is a sub-pkg of ctdb2.5) also from RHGS-Server variant (both RHEL-6 and RHEL-7 based).

Other than this, all looks correct.
Comment 10 Divya 2016-01-12 05:54:27 EST
(In reply to Sreenath G from comment #9)
> (In reply to Divya from comment #8)
> > (In reply to Sreenath G from comment #7)
> > > (In reply to Divya from comment #6)
> > > > Sreenath,
> > > > 
> > > > My comments in line.
> > > > 
> > > > (In reply to Sreenath G from comment #5)
> > > > > Packages added 
> > > > > 
> > > RHGS-3.1u2-RHEL-7
> > > -----------------
> > > 
> > > heketi                 ASL 2.0    N
> > > heketi-devel           ASL 2.0    N
> > > heketi-unit-test-devel ASL 2.0    N
> > > 
> > > > > 
> > > RHGS-3.1u2-RHEL-6
> > > -------------------
> > > heketi                 ASL 2.0    N
> > > heketi-devel           ASL 2.0    N
> > > heketi-unit-test-devel ASL 2.0    N
> > > 
> > > > 
> > > > I have added the heketi package information here:
> > > > http://jenkinscat.gsslab.pnq.redhat.com:8080/job/doc-Red_Hat_Gluster_Storage-
> > > > 3.1-Package_Manifest-en-US%20%28html-single%29/lastStableBuild/artifact/tmp/
> > > > en-US/html-single/index.html
> > > > 
> > > > Could you let me know the Core Package column information for these packages?
> > > > 
> > > > > 
> > > > > 
> > > > > 
> > > > > Packages changed variants from RH-Gluster-Server to RH-Gluster-Samba after
> > > > > RHGS-3.1 update 1
> > > > > ----------------------------------------------------------------------
> > > > > 
> > > 
> > > I am adding ctdb to this list as it has been added as a sub-pkg of samba
> > > package
> > > 
> > > RHGS-3.1.2-RHEL-7
> > > -----------------
> > > libtdb-1.3.6-2.el7rhgs     LGPLv3+    N
> > > libtevent-0.9.25-1.el7rhgs LGPLv3+    N
> > > libtalloc-2.1.2-1.el7rhgs  LGPLv3+    N
> > > ctdb              GPLv3+ and LGPLv3+  N
> > > 
> > > 
> > > > > 
> > > > > 
> > > RHGS-3.1.2-RHEL-6
> > > -----------------
> > > libtdb-1.3.6-2.el6rhs     LGPLv3+    N
> > > libtalloc-2.1.2-1.el6rhs  LGPLv3+    N
> > > libtevent-0.9.25-1.el6rhs LGPLv3+    N
> > > ctdb           GPLv3+ and LGPLv3+    N
> > > 
> > >  
> > > > I have moved these packages to RH-Gluster-Samba section.
> > > > 
> > > > Link to the doc:
> > > > http://jenkinscat.gsslab.pnq.redhat.com:8080/job/doc-Red_Hat_Gluster_Storage-
> > > > 3.1-Package_Manifest-en-US%20%28html-single%29/lastStableBuild/artifact/tmp/
> > > > en-US/html-single/index.html
> > > > 
> > > > > 
> > > > > Packages that need to be deprecated/removed (proposed by Development)
> > > > > ---------------------------------------------------
> > > > > 
> > > 
> > > RHGS-3.1.2-RHEL-7
> > > -----------------
> > > ctdb2.5-2.5.5-7.el7rhgs
> > >  
> > >  
> > > RHGS-3.1.2-RHEL-6
> > > -----------------
> > > ctdb2.5-2.5.5-7.el6rhs
> 
> 
> 
> > > 
> > >  
> > > > Please let me know if I can go ahead and add these packages under
> > > > "Deprecated Packages in Red Hat Gluster Storage 3.1 Update 2 Release"
> > > > section.
> > > 
> > > Yes. Go ahead.
> > > 
> > > > 
> > > > Thanks!
> > 
> > I have made all the changes suggested in Comment 7. Could you review and
> > sign-off?
> > 
> > Link to the latest doc:
> > http://jenkinscat.gsslab.pnq.redhat.com:8080/job/doc-Red_Hat_Gluster_Storage-
> > 3.1-Package_Manifest-en-US%20%28html-single%29/lastStableBuild/artifact/tmp/
> > en-US/html-single/index.html
> 
> Please remove ctdb2.5-debuginfo (which is a sub-pkg of ctdb2.5) also from
> RHGS-Server variant (both RHEL-6 and RHEL-7 based).
> 
> Other than this, all looks correct.

Moved ctdb2.5-debuginfo package to "Deprecated Packages in Red Hat Gluster Storage 3.1 Update 2 Release" section.

Latest doc: http://jenkinscat.gsslab.pnq.redhat.com:8080/job/doc-Red_Hat_Gluster_Storage-3.1-Package_Manifest-en-US%20%28html-single%29/lastStableBuild/artifact/tmp/en-US/html-single/index.html
Comment 12 Neha 2016-01-19 06:03:44 EST
Looks fine to me.

Divya,

###
 ⁠1.11. Deprecated Packages in Red Hat Gluster Storage 3.1 Update 2 Release

The following table lists the package that was removed in Red Hat Gluster Storage 3.1 Update 1 Release. 
###

Should be 3.1 update 2 instead of "3.1 Update 1 Release" ?
Comment 13 Divya 2016-01-20 01:46:27 EST
(In reply to Neha from comment #12)
> Looks fine to me.
> 
> Divya,
> 
> ###
>  ⁠1.11. Deprecated Packages in Red Hat Gluster Storage 3.1 Update 2 Release
> 
> The following table lists the package that was removed in Red Hat Gluster
> Storage 3.1 Update 1 Release. 
> ###
> 
> Should be 3.1 update 2 instead of "3.1 Update 1 Release" ?

My bad, a copy-paste issue. I have updated the version number.

Link to the updated doc: 

http://jenkinscat.gsslab.pnq.redhat.com:8080/job/doc-Red_Hat_Gluster_Storage-3.1-Package_Manifest-en-US%20%28html-single%29/lastStableBuild/artifact/tmp/en-US/html-single/index.html#Nagios_Packages_7
Comment 14 Neha 2016-01-20 02:04:59 EST
Thanks Divya.

Moving it to verified.

Note You need to log in before you can comment on or make changes to this bug.