Bug 1275659 - luarocks for EPEL7 [NEEDINFO]
luarocks for EPEL7
Status: CLOSED ERRATA
Product: Fedora EPEL
Classification: Fedora
Component: luarocks (Show other bugs)
epel7
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Michel Alexandre Salim
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-27 08:54 EDT by Bill McGonigle
Modified: 2016-09-14 20:50 EDT (History)
2 users (show)

See Also:
Fixed In Version: luarocks-2.3.0-1.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-09-14 20:50:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
michel: needinfo? (bill-bugzilla.redhat.com)


Attachments (Terms of Use)
SPEC patch for EL7 (866 bytes, patch)
2015-10-27 09:42 EDT, Bill McGonigle
no flags Details | Diff

  None (edit)
Description Bill McGonigle 2015-10-27 08:54:20 EDT
Hi, Michel,

Please add luarocks to EPEL7.

https://admin.fedoraproject.org/pkgdb/package/luarocks/

Thanks for your work packaging lua for Fedora.
Comment 1 Bill McGonigle 2015-10-27 09:42 EDT
Created attachment 1086846 [details]
SPEC patch for EL7

this SPEC patch gets it to build on EL7.

configure is being passed %{_prefix} but then finding /bin/lua and apparently inferring that lua.h should be at //include/lua.h , erroneously.

It might be more ideal to fix that configure logic, but I passed in --with-lua-include=%{_includedir} which probably should work everywhere too, without modifying the upstream.  

I would have thought the same /bin/lua location would be a problem on Fedora too, though, so maybe I don't understand the root cause.
Comment 2 Michel Alexandre Salim 2016-07-02 11:03:38 EDT
(In reply to Bill McGonigle from comment #1)
> Created attachment 1086846 [details]
> SPEC patch for EL7
> 
> this SPEC patch gets it to build on EL7.
> 
> configure is being passed %{_prefix} but then finding /bin/lua and
> apparently inferring that lua.h should be at //include/lua.h , erroneously.
> 
> It might be more ideal to fix that configure logic, but I passed in
> --with-lua-include=%{_includedir} which probably should work everywhere too,
> without modifying the upstream.  
> 
> I would have thought the same /bin/lua location would be a problem on Fedora
> too, though, so maybe I don't understand the root cause.

Hi Bill,

Thanks for the patch, will take a look. Apologies for the super-long delay, I'm not able to run RHEL/CentOS at work so I'm afraid I've been a bit remiss.

Once the package is branched for EL7, are you interested in helping maintain that branch? I'll happily take co-maintainers.
Comment 3 Michel Alexandre Salim 2016-07-05 06:35:31 EDT
Update: latest luarocks update tested and working fine in EL7 without patch, I'm waiting for the branch request to be approved
Comment 4 Fedora Update System 2016-07-06 10:40:09 EDT
luarocks-2.3.0-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-5d2da6a234
Comment 5 Fedora Update System 2016-07-09 23:18:49 EDT
luarocks-2.3.0-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-5d2da6a234
Comment 6 Fedora Update System 2016-09-14 20:50:24 EDT
luarocks-2.3.0-1.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.