Bug 1275717 - setupNetworks UI | internal engine error when break BOND and remove label in one action
setupNetworks UI | internal engine error when break BOND and remove label in ...
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: BLL.Network (Show other bugs)
3.6.0
x86_64 Linux
unspecified Severity urgent (vote)
: ovirt-3.6.1
: 3.6.1
Assigned To: Alona Kaplan
Meni Yakove
network
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-27 10:44 EDT by Meni Yakove
Modified: 2016-02-10 14:16 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-16 07:16:49 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑3.6.z+
rule-engine: blocker+
ylavi: Triaged+
ylavi: planning_ack+
rule-engine: devel_ack+
rule-engine: testing_ack+


Attachments (Terms of Use)
engine log (1.42 MB, text/plain)
2015-10-27 10:44 EDT, Meni Yakove
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 48071 master MERGED engine: Fix NPE when break bond and remove label from it in one action Never
oVirt gerrit 48134 ovirt-engine-3.6 MERGED engine: Fix NPE when break bond and remove label from it in one action Never

  None (edit)
Description Meni Yakove 2015-10-27 10:44:54 EDT
Created attachment 1086873 [details]
engine log

Description of problem:
Get internal engine error when breaking BOND and remove label from setupNetworks dialog

Version-Release number of selected component (if applicable):
rhevm-3.6.0.2-0.1.el6.noarch

How reproducible:
100%

Steps to Reproduce:
1. Create BOND and attach label to it via setupNetworks dialog > press OK
2. Open setupNetwoeks dialog. remove the label from the BOND and break the BOND > press OK


Actual results:
Internal engine error

Expected results:
BOND and the label are gone 

Additional info:
2015-10-27 16:24:12,197 ERROR [org.ovirt.engine.core.bll.network.host.HostSetupNetworksCommand] (ajp-/127.0.0.1:8702-3) [14a9364] Command 'org.ovirt.engine.core.bll.net
work.host.HostSetupNetworksCommand' failed: null
2015-10-27 16:24:12,197 ERROR [org.ovirt.engine.core.bll.network.host.HostSetupNetworksCommand] (ajp-/127.0.0.1:8702-3) [14a9364] Exception: java.lang.NullPointerExcept
ion
        at org.ovirt.engine.core.bll.network.host.HostSetupNetworksCommand.updateRemovedLabelOnNics(HostSetupNetworksCommand.java:520) [bll.jar:]
        at org.ovirt.engine.core.bll.network.host.HostSetupNetworksCommand.updateLabelsOnNicsToConfigure(HostSetupNetworksCommand.java:513) [bll.jar:]
        at org.ovirt.engine.core.bll.network.host.HostSetupNetworksCommand.applyUserConfiguredNics(HostSetupNetworksCommand.java:501) [bll.jar:]
        at org.ovirt.engine.core.bll.network.host.HostSetupNetworksCommand.access$000(HostSetupNetworksCommand.java:79) [bll.jar:]
        at org.ovirt.engine.core.bll.network.host.HostSetupNetworksCommand$1.runInTransaction(HostSetupNetworksCommand.java:627) [bll.jar:]
        at org.ovirt.engine.core.bll.network.host.HostSetupNetworksCommand$1.runInTransaction(HostSetupNetworksCommand.java:624) [bll.jar:]
        at org.ovirt.engine.core.utils.transaction.TransactionSupport.executeInNewTransaction(TransactionSupport.java:210) [utils.jar:]
        at org.ovirt.engine.core.bll.network.host.HostSetupNetworksCommand.persistNetworkChanges(HostSetupNetworksCommand.java:624) [bll.jar:]
        at org.ovirt.engine.core.bll.network.host.HostSetupNetworksCommand.executeCommand(HostSetupNetworksCommand.java:243) [bll.jar:]
        at org.ovirt.engine.core.bll.CommandBase.executeWithoutTransaction(CommandBase.java:1211) [bll.jar:]
        at org.ovirt.engine.core.bll.CommandBase.executeActionInTransactionScope(CommandBase.java:1355) [bll.jar:]
        at org.ovirt.engine.core.bll.CommandBase.runInTransaction(CommandBase.java:1979) [bll.jar:]
        at org.ovirt.engine.core.utils.transaction.TransactionSupport.executeInSuppressed(TransactionSupport.java:174) [utils.jar:]
        at org.ovirt.engine.core.utils.transaction.TransactionSupport.executeInScope(TransactionSupport.java:116) [utils.jar:]
        at org.ovirt.engine.core.bll.CommandBase.execute(CommandBase.java:1392) [bll.jar:]
        at org.ovirt.engine.core.bll.CommandBase.executeAction(CommandBase.java:374) [bll.jar:]
        at org.ovirt.engine.core.bll.Backend.runAction(Backend.java:475) [bll.jar:]
        at org.ovirt.engine.core.bll.Backend.runActionImpl(Backend.java:457) [bll.jar:]
        at org.ovirt.engine.core.bll.Backend.runAction(Backend.java:413) [bll.jar:]
        at sun.reflect.GeneratedMethodAccessor90.invoke(Unknown Source) [:1.7.0_85]
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) [rt.jar:1.7.0_85]
        at java.lang.reflect.Method.invoke(Method.java:606) [rt.jar:1.7.0_85]
        at org.jboss.as.ee.component.ManagedReferenceMethodInterceptor.processInvocation(ManagedReferenceMethodInterceptor.java:52) [jboss-as-ee.jar:7.5.3.Final-redhat-2]
Comment 1 Red Hat Bugzilla Rules Engine 2015-10-28 06:23:40 EDT
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.
Comment 4 Michael Burman 2015-12-03 02:55:50 EST
Verified on - 3.6.1.1-0.1.el6
Comment 5 Sandro Bonazzola 2015-12-16 07:16:49 EST
According to verification status and target milestone this issue should be fixed in oVirt 3.6.1. Closing current release.

Note You need to log in before you can comment on or make changes to this bug.