This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1275739 - [help] No help for various host/VM devices dialogs in d/s Admin portal
[help] No help for various host/VM devices dialogs in d/s Admin portal
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: rhevm-doc (Show other bugs)
3.6.0
Unspecified Unspecified
medium Severity low
: ovirt-4.1.4
: ---
Assigned To: Greg Sheremeta
Lucie Leistnerova
: UserExperience
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-27 11:42 EDT by Jiri Belka
Modified: 2017-08-07 08:58 EDT (History)
15 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-07 08:31:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: UX
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
pin_vm_to_host - missing help.png (19.49 KB, image/png)
2016-02-11 21:36 EST, Greg Sheremeta
no flags Details
add_host_devices - missing help.png (55.13 KB, image/png)
2016-02-11 21:36 EST, Greg Sheremeta
no flags Details

  None (edit)
Description Jiri Belka 2015-10-27 11:42:54 EDT
Description of problem:

No help for host devices dialogs in Admin portal:

- Add host devices
- Pin VM to Host

Version-Release number of selected component (if applicable):
rhevm-webadmin-portal-3.6.0.2-0.1.el6.noarch

How reproducible:
100%

Steps to Reproduce:
1. Virtual Machine maintab -> select a VM -> Host|VM devices subtabs
2. check action which cause above mentioned dialogs
3. check if there's (?) help icon

Actual results:
help is not existing for the dialogs

Expected results:
should be there and point to docs

Additional info:
Comment 1 Einav Cohen 2015-10-30 08:38:05 EDT
there is really no point in opening CSH-related bugs at this stage - CSH mapping is expected to be updated only around December.
Comment 2 Greg Sheremeta 2016-02-11 21:34:09 EST
For "VM Devices", there are no actions to take, so there is no place to put help.

For "Host Devices", both the "Add Device" and "Pin to another host" dialogs are missing help.
Comment 3 Greg Sheremeta 2016-02-11 21:36 EST
Created attachment 1123330 [details]
pin_vm_to_host - missing help.png
Comment 4 Greg Sheremeta 2016-02-11 21:36 EST
Created attachment 1123331 [details]
add_host_devices - missing help.png
Comment 6 Yaniv Lavi (Dary) 2016-05-09 06:59:16 EDT
oVirt 4.0 Alpha has been released, moving to oVirt 4.0 Beta target.
Comment 8 Tomas Jelinek 2016-05-19 04:23:13 EDT
I have just checked and the help_tags have been in the code since the beginning and the question marks are properly present in the current 3.6. 

Could you please verify that indeed all is there now?
Comment 11 Jiri Belka 2016-05-25 11:15:13 EDT
(In reply to Tomas Jelinek from comment #8)
> I have just checked and the help_tags have been in the code since the
> beginning and the question marks are properly present in the current 3.6. 
> 
> Could you please verify that indeed all is there now?

looks ok in rhevm-4.0.0-10, although actual documention docs urls are 404 for now :)
Comment 12 Jiri Belka 2016-05-25 11:17:56 EDT
(?) in 'Add Host Device' dialog opens document urls _TWICE_. Can you check it please?
Comment 13 Tomas Jelinek 2016-05-30 08:25:49 EDT
Just tested on 3.6.6.2-0.1.el6 and the documentation links open properly. 

The only remaining issue is that in the "add host device" the documentation link opens twice.

It is ugly but harmless, pushing to 4.1
Comment 14 Yaniv Lavi (Dary) 2017-02-07 02:32:55 EST
Anything to do here? Maybe move to QE to test?
Comment 15 Greg Sheremeta 2017-02-07 13:57:32 EST
I didn't know that it opened twice. I somehow missed that. It's probably still broken then. I'll look into.
Comment 18 Greg Sheremeta 2017-04-01 16:15:48 EDT
"The only remaining issue is that in the "add host device" the documentation link opens twice."

Works for me on master. Ready for QE to verify that.
Comment 20 Lucie Leistnerova 2017-05-04 05:43:22 EDT
Help on Add device still opening twice in Firefox 53.0.
Google Chrome 58.0 is OK.

tested in ovirt-engine-4.1.2-0.1.el7.noarch

Note You need to log in before you can comment on or make changes to this bug.